练习赛8.1Prime Ring Problem

Prime Ring Problem

Time Limit : 4000/2000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 9 Accepted Submission(s) : 7
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
思路分析:这是深搜题目,重点在于要把深搜的函数思路熟悉,这个题目有点小记巧就是把质数用一个数组记,质数为0,不是质数为1,打表在时搜索函数。
代码:
#include<stdio.h>
#include<string.h>
int n,visit[25],result[25],prime[38]= {0,0,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1,0,0,0,0,0,1};
void print(int m)
{
    int k;
    for(k=1; k<m; k++)
    {
        printf("%d ",result[k]);
    }
    printf("%d\n",result[m]);
}
void dfs(int sum)
{
    int j;
    if(sum==n&&prime[result[n]+result[1]])
        print(n);
    else
    {
        for(j=2;j<=n;j++)
        {
            if(prime[result[sum]+j]&&!visit[j])
            {
                result[sum+1]=j;
                visit[j]=1;
                dfs(sum+1);
                visit[j]=0;
            }
        }


    }
}
int main()
{
    int i=1;
    while(scanf("%d",&n)!=EOF)
    {
        memset(visit,0,sizeof(int)*21);
        printf("Case %d:\n",i++);
        result[1]=1;
        visit[1]=1;
        dfs(1);
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值