POJ1502 MPI Maelstrom(最短路dijkstra)

MPI Maelstrom
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 5659 Accepted: 3521

Description

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee's research advisor, Jack Swigert, has asked her to benchmark the new system.
``Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert. ``Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.''

``How is Apollo's port of the Message Passing Interface (MPI) working out?'' Swigert asked.

``Not so well,'' Valentine replied. ``To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.''

``Is there anything you can do to fix that?''

``Yes,'' smiled Valentine. ``There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.''

``Ah, so you can do the broadcast as a binary tree!''

``Not really a binary tree -- there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don't necessarily arrive at the destinations at the same time -- there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.'' 

Input

The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100.

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j.

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied.

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on. 

Output

Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.

Sample Input

5
50
30 5
100 20 50
10 x x 10

Sample Output

35

题目大意:给一个邻接矩阵,然后求从第一个节点出发能够走完整个图的单源最短路。根据题意,这是一个无向图,即A[i][j] = A[j][i]。同时A[i][i] = 0是不需要输入的。知道这些,根据题目建立一个邻接矩阵就很简单了。就是输入的时候处理好,然后用dijkstra或者Floyd都可以过,这题我用dijkstra算法。

代码如下:
/**********************************/
/*Problem: 1502  User: shinelin   */
/*Memory: 700K  Time: 0MS         */
/*Language: G++  Result: Accepted */
/**********************************/
#include <cstdio>
#include <iostream>
#include <cstdlib>
#include <ctype.h>
#include <cstring>
#include <string>
#include <list>
#include <map>
#include <queue>
#include <stack>
#include <vector>
#include <algorithm>
#include <cmath>
using namespace std;

#define MAXN 105
#define INF 65535

int T, n;
int A[MAXN][MAXN];
int dist[MAXN];

void Dijkstra()
{
    int s[MAXN];
    for(int i = 1; i <= T; i ++)
    {
        dist[i] = A[1][i];
        s[i] = 0;
    }
    dist[1] = 0;
    s[1] = 1;
    for(int i = 2; i <= T; i ++)
    {
        int Min = INF;
        int u = 1;
        for (int j = 2; j <= T; j ++)
        {
            if(!s[j] && dist[j] < Min)
            {
                Min = dist[j];
                u = j;
            }
        }
        s[u] = 1;
        for (int j = 1; j <= T; j ++)
        {
            if(!s[j] && A[u][j] != INF)
            {
                if(dist[u] + A[u][j] < dist[j])
                {
                    dist[j] =  dist[u] + A[u][j];
                }
            }
        }
    }
}

int main()
{
    while(scanf("%d", &T)!= EOF && T)
    {
        memset(A, 0, sizeof(A));
        for(int i = 2; i <= T; i ++)
        {
            for(int j = 1; j < i; j ++)
            {
                if(scanf("%d", &n) != 0)    //这个输入方式是学习别人的,比较巧妙
                {
                     A[i][j] = A[j][i] = n;
                }
                else
                {
                    scanf("x");
                    A[i][j] = A[j][i] = INF;
                }
            }
        }
        Dijkstra();
        int Max = dist[1];      //耗时最长就是走完整个图的时间,
        for (int i = 2; i <= T; i ++)
        {
            if(dist[i] > Max)
            {
                Max = dist[i];
            }
        }
        printf("%d\n", Max);
    }
    return 0;
}
心得:其实最短路关键就是邻接矩阵的建立。然后这道题我超时了几次,原因是我输入用了while(~scanf("%d", &T) && T),后来换成cin和上面那种都不超时了,也不知道什么原因,真是坑。。。Fighting.



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值