PAT 04-2. File Transfer (25) (并查集)

04-2. File Transfer (25)

题目链接:http://www.patest.cn/contests/mooc-ds/04-2

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input Specification:

Each input file contains one test case. For each test case, the first line contains N (2<=N<=104), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and N. Then in the following lines, the input is given in the format:

I c1 c2  

where I stands for inputting a connection between c1 andc2; or

C c1 c2    

where C stands for checking if it is possible to transfer files betweenc1 and c2; or

S

where S stands for stopping this case.

Output Specification:

For each C case, print in one line the word "yes" or "no" if it is possible or impossible to transfer files betweenc1 and c2, respectively. At the end of each case, print in one line "The network is connected." if there is a path between any pair of computers; or "There are k components." wherek is the number of connected components in this network.

Sample Input 1:
5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S
Sample Output 1:
no
no
yes
There are 2 components.
Sample Input 2:
5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S
Sample Output 2:
no
no
yes
yes
The network is connected.

解题报告:

裸并查集,不过好久不写,路径压缩写漏了,一个点错了一次。。。。

#include <bits/stdc++.h>
using namespace std;
const int maxn = 10005;
int father[maxn];

//int findroot(int x) {
//    if(x != father[x]) {
//        x = findroot(father[x]);
//    }
//    return x;
//}

int findroot(int x) {
    if(x != father[x]) {
        father[x] = findroot(father[x]);
    }
    return father[x];
}
int main() {
    int n, a, b;
    char s[2];
    scanf("%d", &n);
    for (int i = 1; i <= n; i ++) {
        father[i] = i;
    }
    while (scanf("%s", s) != EOF && s[0] != 'S') {
        scanf("%d%d", &a, &b);
        if(s[0] == 'C') {
            if(findroot(a) != findroot(b)) {
                printf("no\n");
            } else {
                printf("yes\n");
            }
        }
        if(s[0] == 'I') {
            int ar = findroot(a);
            int br = findroot(b);
            if(ar != br) {
                father[ar] = br;
                n --;
            }
        }
    }
    if(n == 1) {
        printf("The network is connected.\n");
    } else {
        printf("There are %d components.\n", n);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值