POJ 1860 Currency Exchange(最短路SPFA)

Currency Exchange
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 20926 Accepted: 7494

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4.

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

解题思路:这道题刚开始觉得是单源,直接上dijk了,发现根本无从下手。因为不知道怎么选出新的节点来更新。题目大意是共有N种货币,M个货币交换点,货币交换有比例R、有税率C。同一个货币点从A——》B的R和C与从B——》A不同(无向图)。然后求有没有一种方式能够让货币增值。后来看了别人用BellMan Ford, 自己就用SPFA写了一遍,因为不熟练,WA了好几遍。这也是第一次使用SPFA。dijkstra是一种贪心策略,所以涉及过程的问题似乎不太好解决。学得太浅。
代码如下:
/**********************************/
/*Problem: 1860  User: shinelin   */
/*Memory: 376K  Time: 0MS         */
/*Language: C++  Result: Accepted */
/**********************************/
#include <cstdio>
#include <iostream>
#include <cstdlib>
#include <ctype.h>
#include <cstring>
#include <string>
#include <list>
#include <map>
#include <queue>
#include <stack>
#include <vector>
#include <algorithm>
#include <cmath>
using namespace std;

#define MAXN 105
#define INF  65535

struct Point
{
    double Rate;
    double Comm;
};

Point A[MAXN][MAXN];
int N, M, S;
double V;
double money[MAXN];
queue<int> Q;

int Spfa(int v0)
{
    money[v0] = V;
    int vis[MAXN] = {0};
    Q.push(v0);
    vis[v0] = 1;
    while(!Q.empty())
    {
        int cur = Q.front();
        Q.pop();
        vis[cur] = 0;
        for (int i  = 1; i <= N; i ++)
        {
            if(money[i] < (money[cur] - A[cur][i].Comm) * A[cur][i].Rate)
            {
                money[i] = (money[cur] - A[cur][i].Comm) * A[cur][i].Rate;
                if(money[v0] > V)
                    return 1;
                if(!vis[i])
                {
                    Q.push(i);
                    vis[i] = 1;
                }
            }
        }
    }
    return 0;
}

int main()
{
    int x, y;
    double R, C;
    scanf("%d%d%d%lf",&N, &M, &S, &V);
    for(int i = 1; i <= N; i ++)
    {
        A[i][i].Rate = 1;
    }
    for (int i = 0; i < M; i ++)
    {
        int x, y;
        scanf("%d%d", &x, &y);
        scanf("%lf%lf", &R, &C);
        A[x][y].Rate = R;
        A[x][y].Comm = C;
        scanf("%lf%lf", &R, &C);
        A[y][x].Rate = R;
        A[y][x].Comm = C;
    }
    if(Spfa(S))
    {
        printf("YES\n");
    }
    else
    {
        printf("NO\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值