FZU-Problem 2147 A-B Game

 Problem 2147 A-B Game

Accept: 503    Submit: 1214
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

Fat brother and Maze are playing a kind of special (hentai) game by two integers A and B. First Fat brother write an integer A on a white paper and then Maze start to change this integer. Every time Maze can select an integer x between 1 and A-1 then change A into A-(A%x). The game ends when this integer is less than or equals to B. Here is the problem, at least how many times Maze needs to perform to end this special (hentai) game.

 Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers A and B described above.

1 <= T <=100, 2 <= B < A < 100861008610086

 Output

For each case, output the case number first, and then output an integer describes the number of times Maze needs to perform. See the sample input and output for more details.

 Sample Input

2
5 3
10086 110

 Sample Output

Case 1: 1
Case 2: 7


//题意是不断按A-(A%x)的值改变A值,并且要大于B,问最少能操作几次,满足A<=B

贪心。每次选择A/2+1 作为X值,这样A%X剩下的值是最大的。那每次A变成A/2+1;

#include<cstdio>
#include<iostream>
using namespace std;
int main()
{
    int t,i;
    long long a,b,ans;
    scanf("%d",&t);
    for(i=1;i<=t;i++)
    {
        ans=0;
        cin>>a>>b;
        while(a>b)
        {
            a=a/2+1;
            ans++;
        }
        printf("Case %d: %d\n",i,ans);
    }
    return 0;
}


 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值