HDOJ 1013 Digital Roots

Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
 

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
 

Output
For each integer in the input, output its digital root on a separate line of the output.
 

Sample Input
  
  
24 39 0
 

Sample Output
  
  
6 3

这道题很水,但是不注意就会出错,刚开始没有考虑到输入的数可能无限大,用int和long型可能都没法满足要求,WA了几次之后才发现这个问题,其实把输入当成字符串就没问题了。

#include <iostream>
#include <string>
using namespace std;
int a[10000];

int main (){
    string n;
    while ((cin >> n) && n != "0")
    {
        int sum = 0;
        for (int i = 0;i < n.length();i++)
            sum += n[i] - 48;
        int DigitalRoots(int m);

        cout << DigitalRoots(sum)<<endl;
    }
    return 0;
}

int DigitalRoots(int n){
    int b = 0;
    if (n >= 10)
    {
        for (int i = 0;n > 0; i++)
        {
            a[i] = n % 10;
            n = n / 10;
            b += a[i];
        }
        if (b >= 10)
            DigitalRoots(b);
        else
            return b;
    }
    else
        return n;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值