杭电acm2710 素数的好例子

原题网址:

http://acm.hdu.edu.cn/showproblem.php?pid=2710

题目意思:给定n个数,问这n个数中谁的质因子最大,输出具有最大质因子的那个数,

如果有几个数的最大质因子相同,则输出最前面的那个数

比如3个数1,2,3  结果是3
3个数1,2,4 结果是2


/*
Problem Description
To improve the organization of his farm, 
Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number 
in the range 1..20,000. 
Unfortunately, he is unaware that the cows interpret(体现) some serial numbers as better than others. 
In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.

(Recall that a prime number(素数) is just a number that has no divisors(除数) except for 1 and itself.
The number 7 is prime while the number 6, being divisible by 2 and 3, is not).

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, 
determine the one that has the largest prime factor.

 

Input
* Line 1: A single integer, N

* Lines 2..N+1: The serial numbers to be tested, one per line
 

Output
* Line 1: The integer with the largest prime factor. 
If there are more than one, output the one that appears earliest in the input file.
 

Sample Input
4		
36		
38		
40		
42		
 

Sample Output
38

2014/10/12 星期日
分析:
4		//4=2*2 
36		//36=2*2*3*3
38		//38=2*19  19是最大的
40		//40=2*2*2*5
42		//42=2*3*7
*/
//背景知识:任何数都可以用素数相乘而成
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#define MAX 20000

int pvalue[MAX];
int main(int argc, char *argv[])
{
	int i,j;
	int k;
	int flag;
	int n;
	int nub[5000];
	int max[5000];
	
	pvalue[0]=1;//题目的要求是1为素数 -_-!!
	k=1;
	for(i=2;i<MAX;i++)
	{
		flag=1;
		for(j=2;j<=sqrt((double)i);j++)
		{
			if(i%j==0)
			{
				flag=0;
				break;
			}
		}
		if(flag)
		{
			pvalue[k]=i;
			k++;
		}

	}


	while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<n;i++)
		{
			scanf("%d",&nub[i]);
			j=0;
			while(nub[i]>=pvalue[j])
			{
				if(nub[i]%pvalue[j]==0)
				{
					max[i]=pvalue[j];//找出每个数的最大质因子
				}
				j++;

			}
		}

		int t=max[0];
		int tag=0;
		for(i=1;i<n;i++)
		{
			if(t<max[i])
			{
				t=max[i];
				tag=i;
			}
		}
		printf("%d\n",nub[tag]);


	}









	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值