HDU1789 Doing Homework again 【贪心】

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6878    Accepted Submission(s): 4096


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5
 

Author
lcy
 

Source
 

题意:有n个任务,每个任务完成需要一整天,给出每个任务完成的期限和完不成的惩罚值,求最小惩罚值。

题解:看完这题的第一反应是二分图最优匹配,然后就直接上模板了,结果是超时,后来发现这题可以用贪心,每次选择惩罚值最大的任务安排,安排的规则为从该任务的期限后面往前选择一个没有安排任务的天数,将该任务安插在这一天。

贪心:

#include <stdio.h>
#include <string.h>
#include <algorithm>

#define maxn 1010

struct Node {
	int days, penalty;
} arr[maxn];
bool vis[maxn];

bool cmp(Node a, Node b) {
	return a.penalty > b.penalty;
}

int main() {
	// freopen("stdin.txt", "r", stdin);
	int t, n, i, j, sum, sum2;
	scanf("%d", &t);
	while(t--) {
		scanf("%d", &n);
		sum = sum2 = 0;
		for(i = 0; i < n; ++i) 
			scanf("%d", &arr[i].days);
		for(i = 0; i < n; ++i) {
			scanf("%d", &arr[i].penalty);
			sum += arr[i].penalty;
		}
		std::sort(arr, arr + n, cmp);
		memset(vis, 0, sizeof(vis));
		for(j = 0; j < n; ++j)
			for(i = arr[j].days; i; --i)
				if(!vis[i]) {
					vis[i] = true;
					sum2 += arr[j].penalty;
					break;
				}
		printf("%d\n", sum - sum2);
	}
	return 0;
}

TLE的KM:

#include <stdio.h>
#include <string.h>

#define maxn 1010
#define inf 0x3f3f3f3f

int G[maxn][maxn];
int Lx[maxn], Ly[maxn];
int match[maxn];
bool visx[maxn], visy[maxn];
int slack[maxn], n, m, sum;

bool DFS(int cur) {
	int t, y;
	visx[cur] = true;
	for(y = 1; y <= n; ++y) {
		if(visy[y]) continue;
		t = Lx[cur] + Ly[y] - G[cur][y];
		if(0 == t) {
			visy[y] = true;
			if(-1 == match[y] || DFS(match[y])) {
				match[y] = cur; return true;
			}
		} else if(slack[y] > t) slack[y] = t;
	}
	return false;
}

int KM() {
	int i, j, x, d, ret = 0;
	memset(match, -1, sizeof(int) * (n + 1));
	memset(Ly, 0, sizeof(int) * (n + 1));
	for(i = 1; i <= n; ++i) {
		Lx[i] = -inf;
		for(j = 1; j <= n; ++j)
			if(G[i][j] > Lx[i]) Lx[i] = G[i][j];
	}
	for(x = 1; x <= n; ++x) {
		memset(slack, 0x3f, sizeof(int) * (n + 1));
		while(true) {
			memset(visx, 0, sizeof(bool) * (n + 1));
			memset(visy, 0, sizeof(bool) * (n + 1));
			if(DFS(x)) break;
			d = inf;
			for(i = 1; i <= n; ++i)
				if(!visy[i] && d > slack[i])
					d = slack[i];
			for(i = 1; i <= n; ++i)
				if(visx[i]) Lx[i] -= d;
			for(i = 1; i <= n; ++i)
				if(visy[i]) Ly[i] += d;
				else slack[i] -= d;
		}
	}
	for(i = 1; i <= n; ++i)
		if(match[i] > -1) 
			ret += G[match[i]][i];
	return ret;
}

void getMap() {
	int i, w, j;
	sum = 0;
	scanf("%d", &n);
	memset(G, 0, sizeof(G));
	for(i = 1; i <= n; ++i)
		scanf("%d", &match[i]); // 临时表示第i个任务可以匹配的天数
	for(i = 1; i <= n; ++i) {
		scanf("%d", &w);
		sum += w;
		for(j = 1; j <= match[i]; ++j)
			G[i][j] = w;
	}
}

void solve() {
	printf("%d\n", sum - KM());
}

int main()
{
	// freopen("stdin.txt", "r", stdin);
	int t;
	scanf("%d", &t);
	while(t--) {
		getMap();
		solve();
	}
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值