hdu-1789 Doing Homework again(贪心)

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 24503 Accepted Submission(s): 14083

Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework… Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

Output
For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output

0
3
5

题意

输入给定一个整数T,代表测试用例个数,接下来给定一个N,代表有N门功课,接下来两行,一行代表作业的结束日期,一行代表分数。问:一天只能完成一门作业,在截止期限后完成的作业将扣除相应分数,怎么安排,才能使被扣除的分数最少。

分析

为了保证被扣除分数最少,所以应该把分数最高的先做,所以对数据的排序应该是分数高的在前面,分数相同则截止日期小的在前面。采用贪心算法解决,每次选出当前作业分数最高的,然后从该门作业的截止日期起往前搜,如果有可以利用的日期就标记上。如果截止日期起到第1天都没有可以利用的日期则应该扣除相应分数。

代码

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
const int MAXN=1005;
struct hw{
	int d;//截止日期
	int s;//分数
}H[MAXN];
int f[MAXN];

bool cmp(const hw& a,const hw& b)
{
	if(a.s>b.s)
	return true;
	else if(a.s==b.s&&a.d<b.d)
	return true;
	else
	return false;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--){
		memset(f,0,sizeof(f));
		int n;
		scanf("%d",&n);
		for(int i=1;i<=n;i++) scanf("%d",&H[i].d);
		for(int i=1;i<=n;i++) scanf("%d",&H[i].s);
		sort(H+1,H+n+1,cmp);
		int sum=0;//用来累计被扣除的分数
		for(int i=1;i<=n;i++){
			int j;
			for(j=H[i].d;j>=1;j--){
				if(!f[j]){
					f[j]=1;
					break;
				}
			}
			if(j==0) sum+=H[i].s;
		}
		printf("%d\n",sum);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值