HDU1789-Doing Homework again

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework… Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
Output
For each test case, you should output the smallest total reduced score, one line per test case.
Sample Input
3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4
Sample Output
0
3
5

分析:

题意:
给出要做的N个作业的截止时间和N个作业未按时交所要被扣的分,求被扣分数的最低值。

解析:
离线数据先按被扣分数的大小从高到低排序,在同分的情况下,按截止时间的早晚从晚到到早排序,由于给出的时间不是特别大的原因吧!所以不用数据离散化!开一个1000左右的记录数组就可以!

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring> 
#define N 1005

using namespace std;

struct node{
	int lt,v;
};

node book[N];
int vist[N];

bool cmp(node a,node b)
{
	if(a.v==b.v)
		return a.lt>b.lt;
	return a.v>b.v;
}

int main()
{
	int T,n,sum;
	scanf("%d",&T);
	while(T--)
	{
		sum=0;
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&book[i].lt);
		}
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&book[i].v);
		}
		sort(book+1,book+n+1,cmp);
		int lasttime=-1;
		for(int i=1;i<=n;i++)
		{
			int end=book[i].lt;
			if(!vist[end])
				vist[end]=1;
			else
			{
				while(end>0)
				{
					if(!vist[end])
					{
						vist[end]=1;
						break;
					}
					else
						end--;
				}
				if(end==0)
					sum+=book[i].v; 
			}
		}
		printf("%d\n",sum);
		memset(vist,0,sizeof(vist));
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值