hdu1116—Play on Words(欧拉回路)

题目链接:传送门

Play on Words

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8400    Accepted Submission(s): 2858


Problem Description
Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us. 

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door. 
 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list. 
 

Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times. 
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.". 
 

Sample Input
  
  
3 2 acm ibm 3 acm malform mouse 2 ok ok
 

Sample Output
  
  
The door cannot be opened. Ordering is possible. The door cannot be opened.

题目大意:给你n个单词,问你能否首尾相连,形成一个序列

解题思路:将一个单词看成一条又向边,单词的首尾字母看成两个结点,建图,若图联通 且存在欧拉通路,则所有的单词可以形成一个序列


#include <cstdio>  
#include <cstring>  
#include <cmath>  
#include <iostream>  
#include <queue>
#include <set>
#include <string>
#include <stack>
#include <algorithm>
#include <map>
using namespace std;  
typedef __int64 ll;
const int N = 30;
const int M = 50800;
const int INF = 0x3fffffff;
const int mod = 1e9+7;
const double Pi = acos(-1.0);
const double sm = 1e-9;

int rec[N],parent[N],vis[N];

int find( int a )
{
	int b = a;
	while( b != parent[b] ){
		parent[b] = parent[parent[b]];
		b = parent[b];
	}
	return b;
}

void merge( int a , int b )
{
	int i = find(a);
	int j = find(b);
	if( i != j ) parent[i] = j;
}

void init()
{
	fill( rec , rec+N , 0 );
	fill( vis , vis+N , 0 );
	for( int i = 0 ; i <= N ; ++i ) parent[i]=i;
}

int main()
{
	int T,n;
	scanf("%d",&T);
	while( T-- ){
		init();
		scanf("%d",&n);
		string str;
		for( int i = 0 ; i < n ; ++i ){
			cin >> str;
			int a = str[0]-'a';
			int b = str[str.length()-1]-'a';
			rec[a]--;rec[b]++;
			vis[a] = vis[b] = 1;
			merge(a,b);
		}
		int tot = 0;
		for( int i = 0 ; i < 26 ; ++i ){
			if( i == parent[i] && vis[i] ) ++tot;
		}
		if( tot != 1 ){printf("The door cannot be opened.\n");continue;}
		int r1 = 0,r2 = 0,flag = 0;
		for( int i = 0 ; i < 26 ; ++i ){
			if( rec[i] != 0 && rec[i] != 1 && rec[i] != -1 ){flag = 1;break;}
			if( rec[i] == 1 ) ++r1;
			if( rec[i] == -1 ) ++r2;
		}
		if( flag == 1 ){printf("The door cannot be opened.\n");continue;}
		if( (r1==1&&r2==1)||(r1==0&&r2==0) ) printf("Ordering is possible.\n");
		else printf("The door cannot be opened.\n");
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值