HDU2607 Let the Balloon Rise II

Let the Balloon Rise II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 131    Accepted Submission(s): 37


Problem Description
Contest will be end at 17:00! How excited it is to see balloons floating around.

I knew you had solved the HDOJ 1004 Let the Balloon Rise already, so please settle the another version quickly. I have a lot of balloons and each has a color and I give each of them a number, same color has the same number. For example, red balloon is No.1, pink is No.2, black is No.3 . etc. I also have many rooms to store all the balloons.
There are some rules :
1. Every room stores several balloons but no two have the same color.
2. Collect all the balloons, we can find each color has even number of times of balloons except one.

Your task is to find which is the odd color and calculate its number of times.
 

Input
Input file consists from multiple data sets separated by one or more empty lines.
Each data set represents a sequence of 32-bit (positive) integers (references) which are stored in compressed way.
Each line of input set consists from three single space separated 32-bit (positive) integers X Y Z and they represent following sequence of No.X, X+Z, X+2*Z, X+3*Z, …, X+K*Z, …(while (X+K*Z)<=Y). This line represents that in this room there exists (K+1) balloons whose No. is No.X, No.X+Z, No.X+2*Z, No.X+3*Z, …, No.X+K*Z, …etc.
 

Output
For each input data set you should print to standard output new line of text with two integers separated by single space (first one is No. that occurs odd number of times and second one is count of that kind of balloon).
If all have even number of times output “None.”
 

Sample Input
  
  
1 10 1 1 10 1 1 5 1 6 10 1 1 10 1 4 4 1 1 5 1 2 5 1 2 5 1 2 5 1
 

Sample Output
  
  
None. 4 3 1 1
 

Author
WhereIsHeroFrom
 

Source


#include <stdio.h>
#include <string.h>

#define maxn 100002

int X[maxn], Y[maxn], Z[maxn];
char buf[40];

int main() {
    // freopen("data.in", "r", stdin); 
    int i, id = 0, cnt = 0, ret = 0; // id记录数据块中条数, ret记录最终结果
    while (gets(buf)) {
        if (*buf == NULL) {
            if (id)
                if (ret == 0) puts("None.");
                else {
                    while (id--) {
                        if (ret >= X[id] && ret <= Y[id] && (ret - X[id]) % Z[id] == 0)
                            ++cnt;
                    }
                    printf("%d %d\n", ret, cnt);
                }
            id = cnt = ret = 0;
            continue;
        }

        sscanf(buf, "%d%d%d", &X[id], &Y[id], &Z[id]);
        for (i = X[id]; i <= Y[id]; i += Z[id])
            ret ^= i;
        ++id;
    }
    if (id) 
        if (ret == 0) puts("None.");
        else {
            while (id--) {
                if (ret >= X[id] && ret <= Y[id] && (ret - X[id]) % Z[id] == 0)
                    ++cnt;
            }
            printf("%d %d\n", ret, cnt);
        }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值