[DP] POJ 1163 The Triangle

The Triangle
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 36948 Accepted: 22139

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

非常简单的题目,基本等于水题了,只有一点点DP的思想。第一次编代码如下:

#include <iostream>
#include <cstdio>
using namespace std;
const int MAXN=101;
int a[MAXN][MAXN];
int maxS[MAXN][MAXN];
int main()
{
    int n;
    scanf("%d",&n);
    for (int i=1;i<=n;i++)
        for (int j=1;j<=i;j++)
            scanf("%d",&a[i][j]);

    for (int i=1;i<=n;i++)
        maxS[n][i]=a[n][i];
    for (int i=n-1;i>=1;i--)
    {
        for (int j=1;j<=i;j++)
        {
            maxS[i][j]=a[i][j]+max(maxS[i+1][j],maxS[i+1][j+1]);
        }
    }
    printf("%d\n",maxS[1][1]);
    return 0;
}


 

还可以继续优化。在递推过程中,没必要用二维maxS存储每一个i、j,只要从底层一行行向上递推,只要用一维数组即可。只要存储一行的maxsum值就可以。

 

#include <iostream>
#include <cstdio>
using namespace std;
const int MAXN=101;
int a[MAXN][MAXN];
int *maxS;  //取代maxS[100]数组
int main()
{
    int n;
    scanf("%d",&n);
    for (int i=1;i<=n;i++)
        for (int j=1;j<=i;j++)
            scanf("%d",&a[i][j]);
        maxS=a[n]; //第n行
    for (int i=n-1;i>=1;i--)
        for (int j=1;j<=i;j++)
            maxS[j]=a[i][j]+max(maxS[j],maxS[j+1]);
    printf("%d\n",maxS[1]);
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值