基础DP-POJ1163 The Triangle

题目:

http://poj.org/problem?id=1163

Description:

        7
      3   8
    8   1   0
  2   7   4   4
4   5   2   6   5

   (Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input:

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output:

Your program is to write to standard output. The highest sum is written as an integer.

样例输入:

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

样例输出:

30

解析:

这道题的要求是 计算从顶部开始到底部某处结束的路径上传递的最大数字总和。每一步都可以向左斜向下或向右斜向下。

题目要求很简单,这道题如果使用普通的递归方法解题的话,每两个相邻数字的向下双分支中的第一右分支和第二左分支都会重复计算,最终导致题目判超时。

所以这道题应该使用dp解题。不妨使用两个二维数组,第一个二维数组保存三角形中的所有数字,第二个二维数组的最后一行就是三角形的底,倒数第二行的第一个数字便是三角形底的第一个数字和第二个数字中的较大值加上倒数第二行第一个数字本身,以此类推。例如:

7
38
810
2744
45265

这个三角形中我们保留最后一行:

j
hi
efg
abcd  
45265

那么倒数第二行的a,b,c,d分别就是7,12,10,10

j
hi
efg
7  121010
5265  

倒数第三行的e,f,g分别为20,13,10

j
hi
201310
7121010
45265  

倒数第三行的h,i分别为23,21

30 ( j )   
2321        
201310         
7121010     

4

5265      

于是这道题目的答案存在于j的位置,我们最终只需要输出第二个数组的第一行第一列即为答案。

 AC代码:

#include<iostream>
#include<algorithm>
using namespace std;
#define N 101
int a[N][N];
int n;
int maxsum[N][N];
int main()
{
	int i, j;
	cin >> n;
	for (i = 1; i <= n; i++)
	{
		for (j = 1; j <= i; j++)
		{
			cin >> a[i][j];
		}
	}
	for (i = 1; i <= n; i++)
	{
		maxsum[n][i] = a[n][i];
	}
	for (i = n - 1; i >= 1; i--)
	{
		for (j = 1; j <= i; j++)
		{
			maxsum[i][j] = max(maxsum[i + 1][j], maxsum[i + 1][j + 1]) + a[i][j];
		}
	}
	cout << maxsum[1][1] << endl;
}

cs202 fanyuchen

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值