[bfs] poj3278 Catch that Cow

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 45556 Accepted: 14277
Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a pointN (0 ≤N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 orX+ 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N andK
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

翻译:
农夫知道一头牛的位置,想要抓住它。农夫和牛都位于数轴上,农夫起始位于点N(0<=N<=100000),牛位于点K(0<=K<=100000)。农夫有两种移动方式:
1、从X移动到X-1或X+1,每次移动花费一分钟。
2、从X移动到2*X,每次移动花费一分钟。
假设牛没有意识到农夫的行动,站在原地不动。农夫最少要花多少时间才能抓住牛?
样例说明:农夫从5到17的最快走法是这样: 5 - 10 - 9 - 18 - 17 ,总共4分钟。

一道老题目了,去年就作为例题学过,今天重新敲一遍,代码结构简洁清楚了很多,一些模型也比以前掌握的好多啦~

#include <iostream>
#include<cstring>
#include<queue>
#include<cstdio>
using namespace std;

int N,K;
int vis[100010];

struct node
{
    int x,steps;
};
node p[100010];


int main()
{
    int ans = 0;
    while(cin>>N>>K)
    {
        node a,next;
        a.x = N,a.steps = 0;
        memset(vis,0,sizeof(vis));
        vis[N] = 1;
        queue<node> Q;
        Q.push(a);
        while(!Q.empty())
        {
            a=Q.front();
          //  cout<<a.x<<" "<<a.steps<<endl;
            if (a.x == K)
            {
                ans = a.steps;
                break;
            }

            else
            {
                if( a.x*2<=100000 && !vis[a.x*2])
                {
                    next.x = a.x*2;
                    next.steps = a.steps +1;
                    vis[a.x*2] = 1;
                    Q.push(next);
                }
                if ( a.x+1<=100000 &&!vis[a.x+1] )
                {
                    next.x = a.x+1;
                    next.steps = a.steps+1;
                    vis[a.x+1] = 1;
                    Q.push(next);
                }
                if ( a.x-1>=0 && !vis[a.x-1])
                {
                    next.x = a.x-1;
                    next.steps = a.steps+1;
                    vis[a.x-1] = 1;
                    Q.push(next);
                }

                Q.pop();
            }

        }
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值