poj3278 Catch That Cow

48 篇文章 0 订阅
Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 36079 Accepted: 11123

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:   N  and   K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

完全是BFS,没有什么技巧,主要还是用VISIT标记,防重搜

#include<iostream>
#include<stdio.h>
#include<cstring>
using namespace std; 
struct tree{int x;int step;} queue[800050];
int visit[100050];
int n,k;
int bfs()
{
	int t,w,temp,minx=10000000,xx;
	t=w=1;
	queue[t].x=n;
	visit[n]=1;
	queue[t].step=0;
	while(t<=w)
	{
	
		 xx=queue[t].x;
	
		if(xx>k)
		{
		
			temp=queue[t].step+xx-k;//如果比结果大,只能减,所以可以直接求出来!
			if(temp<minx)
				minx=temp;
			t++;//这里的T一定要加,要不然就错了
			continue;
		}
		if(xx*2<=100000&&(!visit[2*xx]))
		{
		queue[++w].x=xx*2;
		visit[2*xx]=1;//用VISIT来标记,防止重搜
		queue[w].step=queue[t].step+1;
		if(	queue[w].x==k)
		{
			if(queue[w].step<minx)
				return queue[w].step;
			else 
				return minx;
		}
		}
		if(xx+1<=100000&&(!visit[xx+1]))
		{
		queue[++w].x=xx+1;
		visit[xx+1]=1;
		queue[w].step=queue[t].step+1;
		if(	queue[w].x==k)
		{
			if(queue[w].step<minx)
				return queue[w].step;
			else 
				return minx;
		}
		}
		if(xx>=1&&(!visit[xx-1]))
		{
		queue[++w].x=xx-1;
		visit[xx-1]=1;
		queue[w].step=queue[t].step+1;
		if(	queue[w].x==k)
		{
			if(queue[w].step<minx)
				return queue[w].step;
			else 
				return minx;
		}
		}
		t++;
	}
	return -1;
}
int main ()
{
	while(scanf("%d%d",&n,&k)!=EOF)
	{
		memset(visit,0,sizeof(visit));
		if(n>=k)
			printf("%d\n",n-k);
		else
			printf("%d\n",bfs());
	}
	
	return 0;
}


 

 

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值