[搜索] Find the multiple

E - Find The Multiple
Time Limit:1000MS Memory Limit:10000KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111

题目大意是给出一个数n,找出一个数要求是n的倍数,并且这个数的十进制只由1和0组成,明显这样的数不止一个(如果,满足条件一定会有m×10也满足,故不止一种),题目要求输出任意一个满足该条件的m
对于数据1,可知2×5=10,故答案可以得出是10(当然,100,1000…也满足,但是special judge,只用输出一个满足条件的解),其他数据也同理。

刚看的时候以为最大数是200非常大,可能会超过限制,后来发现用unsigned long long 就可以找到相应的位置,所以其实还是可以写。。直接搜索,对每一个被搜索的数字乘以10,就是相当于在该数字后面加零,乘以十加一,就是相当于在该数字后面加1。对每一个数判断该数字是否是n的倍数,在unsigned long long情况下能存得下,经过测试最多到第19层,所以在10^19范围内都能找到相应的答案。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
bool found;

void DFS(unsigned __int64 t ,int n,int k)
{
    if(found)
        return ;
    if(t%n==0) 发现数字
    {
        //标记变量true
        printf("%I64u\n",t);
        found=true;
        return ;
    }
    if(k==19)//到第19层,回溯
        return ;
    DFS(t*10,n,k+1);    //从10*t开始搜索n的倍数,k+1为下一层
    DFS(t*10+1,n,k+1);   
}
int main()
{
    int n;
    while(cin>>n,n)
    {
        found=false;//标记变量,当为true代表搜到了题意第一的m
        DFS(1,n,0);    //从1开始搜n的倍数,第三个参数代表搜的层数,当到第19层时返回(因为第20层64位整数存不下)
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值