Find The Multiple(简单搜索)

Find The Multiple(简单搜索)

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

解题思路:

1.题意:给定一个正整数n,寻找n的一个非零的倍数m,这个m应当在十进制表示时每一位上只包含0或者1。你可以假定n不大于200且m不多于100位。
2.m不大于100位,时间复杂度允许,所以可以一位一位的搜索m,并判断是否能整除n

#include<iostream>
#include<string>
#include<cstring>
#include<memory.h>
using namespace std;
int a[200];
int inx;
int n;
int flag;
void dfs(int k,int last){//last表示每一次%n的余数
    if(flag==1){
        return;
    }
    a[inx++]=k;//m采用字符串存储
    if(last==0){//当能整除时输出m
        for(int i=0;i<inx;i++){
            cout<<a[i];
        }
        cout<<endl;
        flag=1;
        return;
    }
    if(inx==100){
        return;
    }
    dfs(0,(last*10)%n);//添加一个0,比如1->10
    inx--;
    dfs(1,(last*10+1)%n);//添加一个1
    inx--;
    return;
}
int main(){
    while(cin>>n){
        if(n==0){
            break;
        }
        if(n==1){
            cout<<1<<endl;
        }
        else{
            memset(a,0,sizeof(a));
            inx=0;
            flag=0;
            dfs(1,1);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值