hdu5317 RGCDQ

Problem Description
Mr. Hdu is interested in Greatest Common Divisor (GCD). He wants to find more and more interesting things about GCD. Today He comes up with Range Greatest Common Divisor Query (RGCDQ). What’s RGCDQ? Please let me explain it to you gradually. For a positive integer x, F(x) indicates the number of kind of prime factor of x. For example F(2)=1. F(10)=2, because 10=2*5. F(12)=2, because 12=2*2*3, there are two kinds of prime factor. For each query, we will get an interval [L, R], Hdu wants to know  maxGCD(F(i),F(j))   (Li<jR)
 

Input
There are multiple queries. In the first line of the input file there is an integer T indicates the number of queries.
In the next T lines, each line contains L, R which is mentioned above.

All input items are integers.
1<= T <= 1000000
2<=L < R<=1000000
 

Output
For each query,output the answer in a single line. 
See the sample for more details.
 

Sample Input
  
  
2 2 3 3 5
 

Sample Output
  
  
1

1

题意:定义了一个函数F(x),表示x这个数的不同素数因数的个数,然后给你一个区间[L,R],问你任意区间内不同的两个数的最大公约数是多少,这里要发现1000000范围内的最大不同素数因数个数是7,所以用dp[i][j]保存从1到i这i个数不同素数因数的个数。这里先预处理1~1000000的数的不同素数因数的个数,可以用普通素数筛法(这里线性筛法好像不能用,因为线性筛法只能求出这个数的素数因数个数和因数个数)。

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<string>
#include<algorithm>
using namespace std;
#define maxn 1000000
int vis[maxn+10],prime[maxn+10],tot,dp[maxn+10][10],cnt[maxn+10];
void init()
{
    int i,j;cnt[1]=0;
    for(i=2;i<=maxn;i++){
        if(!vis[i]){
            cnt[i]=1;
            for(j=2*i;j<=maxn;j+=i){
                vis[j]=1;
                cnt[j]++;
            }
        }
    }
    for(i=1;i<=7;i++){
        dp[1][i]=0;
    }
    for(i=2;i<=maxn;i++){
        for(j=1;j<=7;j++){
            dp[i][j]=dp[i-1][j];
        }
        dp[i][cnt[i]]++;
    }
}



int main()
{
    int n,m,i,j,T;
    int num1[10];
    init();
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(i=1;i<=7;i++){
            num1[i]=dp[m][i]-dp[n-1][i];
        }
        if(num1[7]>=2){
            printf("7\n");continue;
        }
        if(num1[6]>=2){
            printf("6\n");continue;
        }
        if(num1[5]>=2){
            printf("5\n");continue;
        }
        if(num1[4]>=2){
            printf("4\n");continue;
        }
        if(num1[3]>=2 || (num1[6]==1 && num1[3]==1)){
            printf("3\n");continue;
        }
        if(num1[2]>=2 || (num1[6]==1 && num1[4]==1) || (num1[6]==1 && num1[2]==1) || (num1[4]==1 && num1[2]==1)){
            printf("2\n");continue;
        }
        printf("1\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值