[尺取法] poj3320 Jessica's Reading Problem

Jessica’s Reading Problem
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8531 Accepted: 2732
Description

Jessica’s a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica’s text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica’s text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input

5
1 8 8 8 1
Sample Output
2

为了准备考试,jessica开始读一本很厚的课本。要想通过考试,必须把课本中所有的知识点都掌握。这本书总共有P页,第i页恰好有一个知识点a[i],每个知识点都有一个整数编号。全书中同一个知识点可能会被多次提到,所以她希望通过阅读其中连续的一些页,把所有的知识点都覆盖到。给定每页写到的知识点,求出她要读的最少页数。

假设我们从第s页开始阅读,为了覆盖所有的知识点需要阅读到t,这样的话可以知道如果从s+1开始阅读的话,那么必须阅读到t’≥t页为止。由此这题也可以用到尺取法。

像这样反复地推进区间的开头和末尾,来求满足条件的最小区间的方法被称为尺取法。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <map>
#include <cstring>
#include <set>
using namespace std;
const int MAXN = 1000100;
int P,a[MAXN];

int main()
{
    while(scanf("%d",&P) != EOF)
    {
        set<int> myset;
        for(int i = 0; i < P;i++)
        {
            scanf("%d",&a[i]);
            myset.insert(a[i]);
        }
        int n = myset.size();
        int s = 0, t = 0, num = 0;
        map<int,int> count; //知识点出现一次的映射
        int res = P;
        while(1)
        {
            while(t<P && num < n)
            {
                if (count[a[t++]]++ == 0)
                    num ++;
            }
            if (num < n) break;
            res = min(res,t-s);
           // for(int i = s;i<=t;i++)
           //     printf("%d",i,a[i]);
           // printf("\n");
            if(--count[a[s++]] == 0)
                num--;
        }
        printf("%d\n",res);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值