[dp] hdu 5389 多校联合第八场 Zero Escape

Zero Escape

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 600 Accepted Submission(s): 301

Problem Description
Zero Escape, is a visual novel adventure video game directed by Kotaro Uchikoshi (you may hear about ever17?) and developed by Chunsoft.

Stilwell is enjoying the first chapter of this series, and in this chapter digital root is an important factor.

This is the definition of digital root on Wikipedia:
The digital root of a non-negative integer is the single digit value obtained by an iterative process of summing digits, on each iteration using the result from the previous iteration to compute a digit sum. The process continues until a single-digit number is reached.
For example, the digital root of 65536 is 7, because 6+5+5+3+6=25 and 2+5=7.

In the game, every player has a special identifier. Maybe two players have the same identifier, but they are different players. If a group of players want to get into a door numbered X(1≤X≤9), the digital root of their identifier sum must be X.
For example, players {1,2,6} can get into the door 9, but players {2,3,3} can’t.

There is two doors, numbered A and B. Maybe A=B, but they are two different door.
And there is n players, everyone must get into one of these two doors. Some players will get into the door A, and others will get into the door B.
For example:
players are {1,2,6}, A=9, B=1
There is only one way to distribute the players: all players get into the door 9. Because there is no player to get into the door 1, the digital root limit of this door will be ignored.

Given the identifier of every player, please calculate how many kinds of methods are there, mod 258280327.

Input
The first line of the input contains a single number T, the number of test cases.
For each test case, the first line contains three integers n, A and B.
Next line contains n integers idi, describing the identifier of every player.
T≤100, n≤105, ∑n≤106, 1≤A,B,idi≤9

Output
For each test case, output a single integer in a single line, the number of ways that these n players can get into these two doors.

Sample Input
4
3 9 1
1 2 6
3 9 1
2 3 3
5 2 3
1 1 1 1 1
9 9 9
1 2 3 4 5 6 7 8 9

Sample Output
1
0
10
60

0-1背包问题,给出n个人的id,有两个门,每个门有一个标号,我们记作a和b,现在我们要将n个人分成两组,进入两个门中,使得两部分人的标号的和的树根(sum-1)%9+1分别等于a和b,问有多少种分法。

设dp[i][j]为当前树根为 j 的分类的个数,则状态转移就是用当前的值c[i] 和上次的dp[i-1][0]~dp[i-1][9]
dp[i][(j+c[i]-1)%9+1] += dp[i-1][j]; 这是又当下数字之和之前状态得到的。
dp[i][j] = dp[i-1][j]; 这是通过上次得到的

#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
#define maxn 100005
#define ll __int64
#define INF 0xffffff
using namespace std;
ll dp[maxn][10]; //第i次
ll c[maxn];
const ll mod=258280327;
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,a,b;
        //输入
        scanf("%d%d%d",&n,&a,&b);
        for(int i=1; i<=n; i++) scanf("%I64d",&c[i]);

        memset(dp,0,sizeof(dp));
        dp[0][0]=1;
        ll sum=0;
        for(int i=1; i<=n; i++)
        {
            sum+=c[i];
            for(int j=0; j<10; j++) dp[i][j]=dp[i-1][j];
            for(int j=0; j<10; j++)
            {
                dp[i][(j+c[i]-1)%9+1]+=dp[i-1][j];
                dp[i][(j+c[i]-1)%9+1]%=mod;
            }
        }
        ll ans=0;
        if(((sum-1)%9+1)==(a+b-1)%9+1)
        {
            ans+=dp[n][a];
            if((sum-1)%9+1==a)
                ans--;
        }
        if(a==(sum-1)%9+1) ans++;
        if(b==(sum-1)%9+1) ans++;
        printf("%I64d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值