poj 1459 Power Network(最大流)

Power Network
Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 23459 Accepted: 12284

Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l max(u,v) of power delivered by u to v. Let Con=Σ uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con. 

An example is in figure 1. The label x/y of power station u shows that p(u)=x and p max(u)=y. The label x/y of consumer u shows that c(u)=x and c max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6. 

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.

Source


看到此题时感觉头大,感觉好乱的样子,不知道,题目说的啥,静下心来读一下题目发现,基础题目;
题意:给你n个节点,包括np个发电站,中转站和nc个消费者;
其中,发电站的消耗c(u)为0,消费者的p(U)为0;中转站的p(u)和c(U)都为0;
在这n个点之间有m条电线连接u、v(可以都是电站或者消耗点)两个站点,电线的最大容量为lmax(u,v)。每个发电站的发电量为p,耗电点的最大耗电量为c. 求消费者最大的消耗量;


思路:容易想到用网络流,这算是多源多汇问题,根据白书上提到的建模方法,建立一个超级源,连接每个源(即发电厂),流量为发电厂的发电量,并建立一个超级汇,将所有的消费者连接一条边倒汇,流量为消费者的消耗量,最后只要求s到tde最大流即可;

此外注意一下此题的输入,空格可以随便输入,我用scanf(“%1s%d%1s”。。。);这种方式写的,据说%1s能够忽略空格,制表符回车等;
顺便扯扯自己对于网络流题目的认识:
1:一般一到网络流的题目需要仔细读题,然后建立模型(即构图),构图可以说是网络流题目的关键了,除非有些题目卡时间比较紧还要注意算法优化问题。建立一个正确的模型,我感觉难度指数很高,需要多练;
本题套用了Dinic算法模板(递归求解、邻接表储存)
代码:
#include <iostream>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <stack>
#include <stdlib.h>
#include <string.h>
#include <stdio.h>
#define max(a,b) a>b?a:b
#define min(a,b) a<b?a:b
#define N 110
#define inf 0x3f3f3f3f
using namespace std;
struct Edge
{
    int from,to,cap,flow;
};
struct Dinic
{
    int n,m,s,t;
    vector<Edge>edges;
    vector<int> G[N];
    bool vis[N];
    int d[N];
    int cur[N];
    bool bfs()
    {
        memset(vis,0,sizeof(vis));
        queue<int>Q;
        Q.push(s);
        d[s]=0;
        vis[s]=1;
        while(!Q.empty())
        {
            int x=Q.front();
            Q.pop();
            for(int i=0; i<G[x].size(); i++)
            {
                Edge &e=edges[G[x][i]];
                if(!vis[e.to]&&e.cap>e.flow)
                {
                    vis[e.to]=1;
                    d[e.to]=d[x]+1;
                    Q.push(e.to);
                }
            }
        }
        return vis[t];
    }
    int dfs(int x,int a)
    {
        if(x==t||a==0)
            return a;
        int flow=0,f;
        for(int &i=cur[x]; i<G[x].size(); i++)
        {
            Edge &e=edges[G[x][i]];
            if(d[x]+1==d[e.to]&&(f=dfs(e.to,min(a,e.cap-e.flow)))>0)
            {
                e.flow+=f;
                edges[G[x][i]^1].flow-=f;
                flow+=f;
                a-=f;
                if(!a)
                    break;
            }
        }
        return flow;
    }
    int Maxflow(int s,int t)
    {
        this->s=s,this->t=t;
        int flow=0;
        while(bfs())
        {
            memset(cur,0,sizeof(cur));
            flow+=dfs(s,inf);
        }
        return flow;
    }
    void add_edge(int from,int to,int cap)
    {
        edges.push_back((Edge)
        {
            from,to,cap,0
        });
        edges.push_back((Edge)
        {
            to,from,0,0
        });
        int m=edges.size();
        G[from].push_back(m-2);
        G[to].push_back(m-1);
    }
};
int main()
{
    int n,np,nc,l,a,b,w,i;
    char c[10];
    while(~scanf("%d%d%d%d",&n,&np,&nc,&l))
    {
        Dinic D;
        D.s=n+1,D.t=n+2;
        for(i=1; i<=l; i++)
        {
            getchar();
            scanf("%1s%d,%d%1s%d",c,&a,&b,c,&w);
            D.add_edge(a,b,w);
        }
        for(i=0; i<np; i++)
        {
            getchar();
            scanf("%1s%d%1s%d",c,&a,c,&b);
            D.add_edge(D.s,a,b);
        }
        for(i=0; i<nc; i++)
        {
            getchar();
            scanf("%1s%d%1s%d",c,&a,c,&b);
            D.add_edge(a,D.t,b);
        }
        int flow=D.Maxflow(D.s,D.t);
        printf("%d\n",flow);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值