HDU 1253 胜利大逃亡 BFS谁说优先队列不能过的!

胜利大逃亡
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31263 Accepted Submission(s): 11630

Problem Description
Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.

Input
输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块……),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.

Output
对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.

Sample Input
1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0

Sample Output
11

http://acm.hdu.edu.cn/showproblem.php?pid=1253

一看这个题目和1240感觉是一样的,就直接BFS优先队列写了,也没剪枝什么的,直接超时,然后看了Discuss,很多都说优先队列不能解这个题,真就不明白了,明明优先队列应该比普通队列快的,看了大牛的提示之后,两个地方进行了剪枝。
未进BFS之前,应先判断T>=(A+B+C-3),这个剪枝很重要,没有这个我直接无限TLE,还有一个剪枝就是当next.step>T时,不再继续找下去。

上面2个是普通队列,下面2个是优先队列,在我的代码里优先队列还是比普通队列快(C++)情况下



#include <iostream>
#include <stdio.h> 
#include <queue>
using namespace std;
int A,B,C,T;
int edge[55][55][55];
int sta[55][55][55];
int mina;
struct node{
    int x,y,z;
    int step;
/*  friend bool operator <(node a,node b)
    {
        return a.step>b.step;
    }*/ 
};
int dirx[6]={1,-1,0,0,0,0};
int diry[6]={0,0,1,-1,0,0};
int dirz[6]={0,0,0,0,1,-1};
bool Judge(int x,int y,int z,int t)
{
    if(x<0||x>=A||y<0||y>=B||z<0||z>=C||edge[x][y][z]==1||sta[x][y][z]<=t)
    return true;
    return false;

}
bool BFS()
{
//  priority_queue<node>Q;
    queue<node>Q;
    node cur,next;
    cur.x=0;
    cur.y=0;
    cur.z=0;
    cur.step=0;
    sta[0][0][0]=0;
    Q.push(cur);
    while(!Q.empty())
    {
    //  cur=Q.top();
        cur=Q.front();
        Q.pop();
        if(cur.x==A-1&&cur.y==B-1&&cur.z==C-1)
        {
            mina=cur.step;
            if(mina<=T)
            return true;
            return false;
        }
        for(int i=0;i<6;i++)
        {
            next.x=cur.x+dirx[i];
            next.y=cur.y+diry[i];
            next.z=cur.z+dirz[i];
            next.step=cur.step+1;
            if(next.step>T)//剪枝一
            continue;
            if(Judge(next.x,next.y,next.z,next.step))
            continue;

            sta[next.x][next.y][next.z]=next.step;
            Q.push(next);
        }

    }
    return false;
}
int main(int argc, char *argv[])
{
    int k;
    cin>>k;
    while(k--)
    {
    scanf("%d%d%d%d",&A,&B,&C,&T);
    for(int k=0;k<A;k++)
    for(int i=0;i<B;i++)
    for(int j=0;j<C;j++)
    {scanf("%d",&edge[k][i][j]);
        sta[k][i][j]=999;
    }
    if(T<(A+B+C-3))//剪枝二 个人认为很重要
    cout<<-1<<endl;
    else 
    {
    if(BFS())
    cout<<mina<<endl;
    else 
    cout<<-1<<endl;
    }
    }       
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值