HDU 1274


Sample Input
  
  
2 1(1a2b1(ab)1c) 3(ab2(4ab))
 

Sample Output
  
  
abbabc abaaaabaaaababaaaabaaaababaaaabaaaab

#include<stdio.h> 
#include<ctype.h> 
#include<string.h> 
char s[260]; 
int dfs(int ith)
{ 
	int k,e; 
	char c; 
	for(c=s[ith++];ith<=strlen(s)&&c!=')';c=s[ith++])//递归结束的条件是字符串结束或遇到右括号  
	{ 
		for(k=0;isdigit(c);c=s[ith++]) 
			k=k*10+c-'0'; 
		if(!k) k=1;
		if(c=='(')
		{ 
			while(k--) 
				e=dfs(ith);
			ith=e;//重置ith的值,到下层递归结束的位置  
			
		} 
		else{ 
			while(k--) 
				putchar(c); 
		} 
	} 
	if(c==')') 
		return ith;//返回本次读到结尾的位置 
	
} 
int main() 
{ 
	int n; 
	scanf("%d",&n);
	while(n--) 
	{ 
		scanf("%s",s); 
		dfs(0);//进入递归  
		printf("\n"); 
	} 
	return 0; 
}
/*
99
3(2a2(ab))aa
*/


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值