uva 10306 - e-Coins

Problem G

e-Coins

Input: standard input

Output: standard output

Time Limit: 10 seconds

Memory Limit: 32 MB

At the Department for Bills and Coins, an extension of today's monetary system has newly been proposed, in order to make it fit the new economy better. A number of new so called e-coins will be produced, which, in addition to having a value in the normal sense of today, also have an InfoTechnological value. The goal of this reform is, of course, to make justice to the economy of numerous dotcom companies which, despite the fact that they are low on money surely have a lot of IT inside. All money of the old kind will keep its conventional value and get zero InfoTechnological value.

To successfully make value comparisons in the new system, something called the e-modulus is introduced. This is calculated asSQRT(X*X+Y*Y), where X and Y hold the sums of the conventional and InfoTechnological values respectively. For instance, money with a conventional value of $3 altogether and an InfoTechnological value of $4 will get an e-modulus of $5. Bear in mind that you have to calculate the sums of the conventional and InfoTechnological values separately before you calculate the e-modulus of the money.

To simplify the move to e-currency, you are assigned to write a program that, given the e-modulus that shall be reached and a list of the different types of e-coins that are available, calculates the smallest amount of e-coins that are needed to exactly match the e-modulus. There is no limit on how many e-coins of each type that may be used to match the given e-modulus.

Input

A line with the number of problems n (0<n<=100), followed by n times:

  • A line with the integers m (0<m<=40) and S (0<S<=300), where m indicates the number of different e-coin types that exist in the problem, and S states the value of the e-modulus that shall be matched exactly.
  • m lines, each consisting of one pair of non-negative integers describing the value of an e-coin. The first number in the pair states the conventional value, and the second number holds the InfoTechnological value of the coin.

When more than one number is present on a line, they will be separated by a space. Between each problem, there will be one blank line.

 

Output

The output consists of n lines. Each line contains either a single integer holding the number of coins necessary to reach the specified e-modulus Sor, if S cannot be reached, the string "not possible".

Sample Input:

3 
2 5 
0 2 
2 0

3 20 
0 2 
2 0 
2 1

3 5 
3 0 
0 4 
5 5

Sample Output:

not possible 
10 
2



看这幅图就应该能看出是二维完全背包问题了。这题我是暴力枚举二维背包容量x,y(x*x+y*y=s*s),情况并不多。 转移方程dp[j][k]=dp[j-x[i]][k-y[i]];

其实这题是考虑有没有装满(价值==容量),即背包里面较为特殊的一类问题,可以直接三重for递推的。初始化除dp[0][0]=0外,其余为inf,像无法装满的状态更新时min(inf,inf+1),因此最后仍为inf,这个就是判断能否装满的条件,当然为了保险起见,可以只在if(dp!=inf)时,去更新,这样最后那些无法装满的状态时更新不到的了,比前面一种更可靠,随个人能力发挥吧!


暴力枚举代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#define Maxn 50
using namespace std;

int x[Maxn],y[Maxn];
int dp[310][310];
const int inf=1<<30;
void cp_pack(int m,int cx,int cy){
    for(int i=0;i<=cx;i++)
        for(int j=0;j<=cy;j++)
            dp[i][j]=inf;
    dp[0][0]=0;
    for(int i=0;i<m;i++)
        for(int j=x[i];j<=cx;j++)
            for(int k=y[i];k<=cy;k++)
                dp[j][k]=min(dp[j][k],dp[j-x[i]][k-y[i]]+1);
}
int main()
{
    int n,m,s;
    scanf("%d",&n);
    while(n--){
        scanf("%d%d",&m,&s);
        for(int i=0;i<m;i++)
            scanf("%d%d",x+i,y+i);
        int ans=inf;
        for(int i=0;i<=s;i++){
            for(int j=0;j<=s;j++)
                if(i*i+j*j==s*s){
                    cp_pack(m,i,j);
                    ans=min(ans,dp[i][j]);
                }
        }
        if(ans==inf) printf("not possible\n");
        else printf("%d\n",ans);
    }
	return 0;
}

直接递推代码可参考: 点击打开链接


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值