Where is the Marble? uva 计数排序

Where is the Marble? 

Raju and Meena love to play with Marbles. They have got a lotof marbles with numbers written on them. At the beginning, Rajuwould place the marbles one after another in ascending order ofthe numbers written on them. Then Meena would ask Raju tofind the first marble with a certain number. She would count1...2...3. Raju gets one point for correct answer, and Meena getsthe point if Raju fails. After some fixed number of trials thegame ends and the player with maximum points wins. Today it'syour chance to play as Raju. Being the smart kid, you'd be takingthe favor of a computer. But don't underestimate Meena, she hadwritten a program to keep track how much time you're taking togive all the answers. So now you have to write a program, whichwill help you in your role as Raju.

Input 

There can be multiple test cases. Total no of test cases is less than 65. Each test case consistsbegins with 2 integers: N the number of marbles and Q the number of queries Mina wouldmake. The next N lines would contain the numbers written on the N marbles. These marblenumbers will not come in any particular order. Following Q lines will have Q queries. Beassured, none of the input numbers are greater than 10000 and none of them are negative.

Input is terminated by a test case where N = 0 and Q = 0.

Output 

For each test case output the serial number of the case.

For each of the queries, print one line of output. The format of this line will depend uponwhether or not the query number is written upon any of the marbles. The two different formatsare described below:

  • `x found at y', if the first marble with number x was found at position y.Positions are numbered 1, 2,..., N.
  • `x not found', if the marble with number x is not present.

Look at the output for sample input for details.

Sample Input 

4 1
2
3
5
1
5
5 2
1
3
3
3
1
2
3
0 0

Sample Output 

CASE# 1:
5 found at 4
CASE# 2:
2 not found
3 found at 3

解决方案:快排可以直接水过,但计数排序比直接快排好很多。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int num[100000];
int main(){

   int N,Q,k=0;
   while(~scanf("%d%d",&N,&Q)&&(Q+N)){
   int max=0,a;
   memset(num,0,sizeof(num));
    for(int i=0;i<N;i++){
        scanf("%d",&a);
        max=(a>max?a:max);
        num[a]++;
    }
    int sum=0;
    for(int i=0;i<=max;i++)
    {
        if(num[i]) {
            sum+=num[i];
            num[i]=sum-num[i]+1;
        }
    }
    cout<<"CASE# "<<++k<<":"<<endl;
    for(int i=0;i<Q;i++)
    {
        int s;
        scanf("%d",&s);
        if(num[s])
        cout<<s<<" found at "<<num[s]<<endl;
        else
        cout<<s<<" not found"<<endl;
    }

   }
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值