Getting in Line uva 回溯

 Getting in Line 

Computer networking requires that the computers in the network be linked.

This problem considers a ``linear" network in which the computers are chainedtogether so that each is connected to exactly two others except for the two computers on the ends of the chain which are connected to only one other computer. A picture is shown below. Here the computers are the black dots and their locations in the network are identified by planar coordinates (relative to a coordinate system not shown in the picture).

Distances between linked computers in the network are shown in feet.

For various reasons it is desirable to minimize the length of cable used.

Your problem is to determine how the computers should be connected into such a chain to minimize the total amount of cable needed. In the installation being constructed, the cabling will run beneath the floor, so the amount of cable used to join 2 adjacent computers on the network will be equal to the distance between the computers plus 16 additional feet of cable to connect from the floor to the computers and provide some slack for ease of installation.

The picture below shows the optimal way of connecting the computers shownabove, and the total length of cable required for this configuration is (4+16)+ (5+16) + (5.83+16) + (11.18+16) = 90.01 feet.

Input

The input file will consist of a series of data sets. Each data set will begin with a line consisting of a single number indicating the number of computers in a network. Each network has at least 2 and at most 8 computers. A value of 0 for the number of computers indicates the end of input.

After the initial line in a data set specifying the number of computers in a network, each additional line in the data set will give the coordinates of a computer in the network. These coordinates will be integers in the range 0 to 150. No two computers are at identical locations and each computer will be listed once.

Output

The output for each network should include a line which tells the number of the network (as determined by its position in the input data), and one line for each length of cable to be cut to connect each adjacent pair of computers in the network. The final line should be a sentence indicating the total amount of cable used.

In listing the lengths of cable to be cut,traverse the network from one end to the other. (It makes no difference atwhich end you start.) Use a format similar to the one shown in the sample output, with a line of asterisks separating output for different networks and with distances in feet printed to 2 decimal places.

Sample Input

6
5 19
55 28
38 101
28 62
111 84
43 116
5
11 27
84 99
142 81
88 30
95 38
3
132 73
49 86
72 111
0

Sample Output

**********************************************************
Network #1
Cable requirement to connect (5,19) to (55,28) is 66.80 feet.
Cable requirement to connect (55,28) to (28,62) is 59.42 feet.
Cable requirement to connect (28,62) to (38,101) is 56.26 feet.
Cable requirement to connect (38,101) to (43,116) is 31.81 feet.
Cable requirement to connect (43,116) to (111,84) is 91.15 feet.
Number of feet of cable required is 305.45.
**********************************************************
Network #2
Cable requirement to connect (11,27) to (88,30) is 93.06 feet.
Cable requirement to connect (88,30) to (95,38) is 26.63 feet.
Cable requirement to connect (95,38) to (84,99) is 77.98 feet.
Cable requirement to connect (84,99) to (142,81) is 76.73 feet.
Number of feet of cable required is 274.40.
**********************************************************
Network #3
Cable requirement to connect (132,73) to (72,111) is 87.02 feet.
Cable requirement to connect (72,111) to (49,86) is 49.97 feet.
Number of feet of cable required is 136.99.

解决方案:用回溯法,用dfs遍历所有的可能,找出最小值,同时还进行剪枝,以提高效率。具体做法代码解释。

代码:

#include<cstdio>
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
int cur[200],ans[200];
bool vis[200];
double X[200],Y[200];
double length(double ax,double ay,double bx,double by){

   return sqrt((ax-bx)*(ax-bx)+(ay-by)*(ay-by));
}///计算两点的距离
int n;
double Min;
void dfs(int Cur,double sum){

  if(Cur==n){
    if(sum<Min)///更新最小值
    {
      Min=sum;
      memcpy(ans,cur,sizeof(cur));
    }///连了n台电脑,本次深搜结束
      return ;///深搜结束
  }
   if(sum>=Min) return ;///剪枝,这个可增加效率,如果没连完电脑就比前面所连的最小值大,此次深搜结束
   for(int i=0;i<n;i++)
   {
       if(vis[i]) continue;///若点已访问,下一点
       vis[i]=true;///标记访问
       cur[Cur]=i;///记录当前顺序要连的电脑
       if(Cur==0)///若cur为0,这表示从另一个起点开始,直接进入第二个点
       {
           dfs(Cur+1,0);///进入第二点
       }
       else {///若不是起点,则要加上两点间的距离。(该点与前一点的距离)
        double t=length(X[cur[Cur-1]],Y[cur[Cur-1]],X[cur[Cur]],Y[cur[Cur]]);
        dfs(Cur+1,sum+t+16);
       }
       vis[i]=false;///另外注意回来时去掉访问标记。
   }
}
int main(){

   int k=0;
   while(~scanf("%d",&n)&&n){
    for(int i=0;i<n;i++){
        scanf("%lf %lf",&X[i],&Y[i]);
    }
    Min=2147483646.0;
    for(int i=0;i<n;i++) cur[i]=i;///对连接的电脑的顺序初始化
    memset(vis,false,sizeof(vis));///访问标记初始化
    dfs(0,0);
    printf("**********************************************************\n");
    printf("Network #%d\n",++k);
    for(int i=0;i<n-1;i++)
    {
        printf("Cable requirement to connect (%.0lf,%.0lf) to (%.0lf,%.0lf) is %.2lf feet.\n",X[ans[i]],Y[ans[i]],X[ans[i+1]],Y[ans[i+1]],length(X[ans[i]],Y[ans[i]],X[ans[i+1]],Y[ans[i+1]])+16);
    }
    printf("Number of feet of cable required is %.2lf.\n",Min);
   }

   return 0;
}




                
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值