23 Out of 5 uva+回溯

23 Out of 5

Input: standard input

Output: standardoutput

Time Limit: 1 second

Memory Limit: 32 MB

Your task is to writea program that can decide whether you can find an arithmetic expression consistingof five given numbers (1<=i<=5) that will yieldthe value 23.
For this problem we will only consider arithmetic expressions of the followingfrom:

 
where : {1,2,3,4,5} -> {1,2,3,4,5} is a bijective function
and  {+,-,*} (1<=i<=4)

Input

The Input consists of 5-Tupelsof positive Integers, each between 1 and 50.
Input is terminated by a line containing five zero's. This line should not beprocessed.

Output

For each 5-Tupel print"Possible" (without quotes) if their exists an arithmetic expression(as described above) that yields 23. Otherwise print "Impossible".

Sample Input

1 1 1 1 1
1 2 3 4 5
2 3 5 7 11
0 0 0 0 0

Sample Output

Impossible
Possible
Possible
解决方案:搞了半天,原来顺序可以换的。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int a[5];
bool vis[5];
bool flag;
void dfs(int s,int sum){
   if(s==5){
    if(sum==23) flag=true;
    return ;
   }
   for(int i=0;i<5;i++){
    if(!vis[i]){
            vis[i]=true;
    if(s==0)
    {dfs(s+1,a[i]);}
    else {dfs(s+1,sum-a[i]);
    dfs(s+1,sum*a[i]);
    dfs(s+1,sum+a[i]);}
    vis[i]=false;
    }
   }

}
int main(){

   while(~scanf("%d%d%d%d%d",&a[0],&a[1],&a[2],&a[3],&a[4])&&(a[0]+a[1]+a[2]+a[3]+a[4])){
    flag=false;
    memset(vis,false,sizeof(vis));
    dfs(0,0);
    if(flag) cout<<"Possible\n";
    else cout<<"Impossible\n";
   }
   return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值