Ice_cream’s world III+最短路kruskal+水题+HDU

 

Ice_cream’s world III

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 759    Accepted Submission(s): 254


Problem Description
ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every city to the capital. The project’s cost should be as less as better.
 

Input
Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.
 

Output
If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.
 

Sample Input
      
      
2 1 0 1 10 4 0
 

Sample Output
      
      
10 impossible
解决方案:还是模板,练一下码模板。
code:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#define MMAX 2003
using namespace std;
struct edge
{
    int from;///起点
    int to;///终点
    int dis;///路长
    bool operator<(const edge &a)const
    {
        return dis>a.dis;
    }

};
//edge store[1003];
int N,M,result;
int fa[MMAX];
priority_queue<edge >Q;
void store()
{
    while(!Q.empty())Q.pop();
    for(int i=0; i<M; i++)
    {
        edge temp;
        scanf("%d%d%d",&temp.from,&temp.to,&temp.dis);
        Q.push(temp);
    }
}
void init_fa()
{
    for(int i=0; i<=N; i++) fa[i]=i;
}
int faset(int x)
{
    return x!=fa[x]?fa[x]=faset(fa[x]):x;
}
bool judge()
{
    int f=faset(0);
    for(int i=0; i<N; i++)
    {
        if(f!=faset(i)) return false;
    }
    return true;
}
void kruskal()
{

    init_fa();
    result=0;
    while(!Q.empty())
    {
        edge temp=Q.top();
        Q.pop();
        int x=faset(temp.to),y=faset(temp.from);
        if(x!=y)
        {
            result+=temp.dis;
            fa[x]=y;
        }


    }

}
int main()
{
    while(~scanf("%d%d",&N,&M))
    {

        store();
        kruskal();
        if(judge())
        printf("%d\n",result);
        else printf("impossible\n");
        cout<<endl;

    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值