Sweet and Sour Rock+spoj+简单dp

154. Sweet and Sour Rock

Problem code: ROCK


A manufacturer of sweets has started production of a new type of sweet called rock. Rock comes in sticks composed of one-centimetre-long segments, some of which are sweet, and the rest are sour. Before sale, the rock is broken up into smaller pieces by splitting it at the connections of some segments.

Today's children are very particular about what they eat, and they will only buy a piece of rock if it contains more sweet segments than sour ones. Try to determine the total length of rock which can be sold after breaking up the rock in the best possible way.

Input

The input begins with the integer t, the number of test cases. Then t test cases follow.

For each test case, the first line of input contains one integer N - the length of the stick in centimetres (1<=N<=200). The next line is a sequence of N characters '0' or '1', describing the segments of the stick from the left end to the right end ('0' denotes a sour segment, '1' - a sweet one).

Output

For each test case output a line with a single integer: the total length of rock that can be sold after breaking up the rock in the best possible way.

Example

Sample input:
2
15
100110001010001
16
0010111101100000

Sample output:
9
13
解决方案:假设在j处切,这状态方程为:dp[i]=max{dp[i],dp[j]+i-j+1}前提是i到j之间甜的比酸的多。
code:
#include<iostream>
#include<cstring>
#include<cstdio>
#define MMAX 220
using namespace std;
int sum[2][MMAX];
int dp[MMAX];
char str[MMAX];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        int n;
        scanf("%d",&n);
        memset(sum,0,sizeof(sum));
        getchar();
        scanf("%s",str);
        for(int i=1;i<=n;i++){
            sum[0][i]=sum[0][i-1];
            sum[1][i]=sum[1][i-1];
            sum[str[i-1]-'0'][i]++;
        }
        dp[0]=0;
        for(int i=1;i<=n;i++){
            dp[i]=dp[i-1];
            for(int j=1;j<=i;j++){
                int m0=sum[0][i]-sum[0][j-1];
                int m1=sum[1][i]-sum[1][j-1];
                if(m0>=m1) continue;
                dp[i]=max(dp[i],dp[j-1]+i-j+1);
            }
        }
        printf("%d\n",dp[n]);


    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值