hdu 5631 (Rikka with Graph)

Rikka with Graph (并查集)

Rikka with Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1049    Accepted Submission(s): 508


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has a non-direct graph with n vertices and n+1 edges. Rikka can choose some of the edges (at least one) and delete them from the graph.

Yuta wants to know the number of the ways to choose the edges in order to make the remaining graph connected.

It is too difficult for Rikka. Can you help her?
 

Input
The first line contains a number T(T30) ——The number of the testcases.

For each testcase, the first line contains a number n(n100) .

Then n+1 lines follow. Each line contains two numbers u,v , which means there is an edge between u and v.
 

Output
For each testcase, print a single number.
 

Sample Input
  
  
1 3 1 2 2 3 3 1 1 3
 

Sample Output
  
  
9
 题意:给出n个节点,n+1条边,若任意去掉几条边后仍连通,问有几种方案。
题解:至少有n-1条边才能构成连通图,所以可以去掉一条边或两条边,暴力就行。
代码:
//B
#include<cstdio>
using namespace std;
int fa[1010];

struct node{//自己没想到要用结构体
	int a,b;
}s[110];
void init(){
	for (int i=1;i<110;i++){
		fa[i]=i;
	}
}
int find(int x){
	if (x!=fa[x]){
		fa[x]=find(fa[x]);
	}
	return fa[x];
}
void Union(int a,int b){
	a = find(a);
	b=find(b);
	if (a!=b)
	fa[a]=b;
}

int main(){
	int t,n;
	int num,sum;
	scanf ("%d",&t);
	while (t--){
		scanf ("%d",&n);	
		num=0; 
		for (int i=1;i<=n+1;i++){
			scanf ("%d %d",&s[i].a,&s[i].b);
		}
		for (int i=1;i<=n+1;i++){去掉第i条边
			
			init();
			for (int j=1;j<=n+1;j++){
				if (i==j) continue;
				Union(s[j].a,s[j].b);
			}
			sum=0;
			for (int k=1;k<=n;k++){
				if (k==fa[k])
				sum++;
			}
			if (sum==1)
			num++;
		}
		
		for (int i=1;i<=n+1;i++){
			
			for (int j=i+1;j<=n+1;j++){//去掉第i条边和第j条边
				init();
				for (int k=1;k<=n+1;k++){
					if (i==k||j==k) continue;
					Union(s[k].a,s[k].b);
				}
				sum=0;
				for (int k=1;k<=n;k++){
					if (fa[k]==k)//找根节点
					sum++;
				}
				if (sum==1)
				num++;
			}
		}
		printf ("%d\n",num);
	}
	return 0;
	
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值