HDU 5631

Minimum Cut-Cut
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has a non-direct graph with n vertices and n+1 edges. Rikka can choose some of the edges (at least one) and delete them from the graph.

Yuta wants to know the number of the ways to choose the edges in order to make the remaining graph connected.

It is too difficult for Rikka. Can you help her?
Input
The first line contains a number ——The number of the testcases.

For each testcase, the first line contains a number .

Then n+1 lines follow. Each line contains two numbers , which means there is an edge between u and v.
Output
For each testcase, print a single number.
Sample Input
1
3
1 2
2 3
3 1
1 3
Sample Output
9

题意:给出n个点,与n+1条边,问你有多少种方式去边,使这n个点仍然联通;
题解:暴力解题法,先去一条边查看是否联通,然后再去两条边查看是否联通

#include <stdio.h>
#define M 110

int pre[M], n;
struct node
{
    int from, to;
};
node no[M];
int find(int a)
{
    int r = a;
    while(r != pre[r])
    {
        r = pre[r];
    }
    int i=a, j;
    while(r != pre[i])
    {
        j = pre[i];
        pre[i] = r;
        i = pre[i];
    }
    return r;
}

void join(int x, int y)
{
    int fx = find(x);
    int fy = find(y);
    if(fx != fy)
    {
        pre[fx] = fy;
    }
}
void zl()
{
    for(int i=0; i<=n+1; i++)
    {
        pre[i] = i;
    }
}
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &n);
        for(int i=0; i<=n; i++)
        {
            scanf("%d%d", &no[i].from, &no[i].to);
        }
        int sum = 0;
        for(int i=0; i<=n; i++)
        {
            zl();
            for(int k=0; k<=n; k++)
            {
                if(i != k)
                {
                    join(no[k].from, no[k].to);
                }
            }
            int ok = 0;
            for(int k=1; k<=n; k++)
            {
                if(pre[k] == k)
                {
                    ok++;
                }
            }
            if(ok == 1)
            {
                sum++;
            }
        }
        for(int i=0; i<=n; i++)
        {
            for(int j=i+1; j<=n; j++)
            {
                zl();
                for(int k=0; k<=n; k++)
                {
                    if(j!=k && i!= k)
                    {
                        join(no[k].from, no[k].to);
                    }
                }
                int ok = 0;
                for(int k=1; k<=n; k++)
                {
                    if(pre[k] == k)
                    {
                        ok++;
                    }
                }
                if(ok == 1)
                {
                    sum++;
                }
            }
        }
        printf("%d\n", sum);

    }


    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值