前缀和 hdu 5480 (Conturbatio)

Conturbatio

Description

There are many rook on a chessboard, a rook can attack the row and column it belongs, including its own place. 

There are also many queries, each query gives a rectangle on the chess board, and asks whether every grid in the rectangle will be attacked by any rook? 

Input

The first line of the input is a integer  , meaning that there are   test cases. 

Every test cases begin with four integers 
 is the number of Rook,   is the number of queries. 

Then   lines follow, each contain two integers   describing the coordinate of Rook. 

Then   lines follow, each contain four integers   describing the left-down and right-up coordinates of query. 






Output

For every query output "Yes" or "No" as mentioned above.

Sample Input

2
2 2 1 2
1 1
1 1 1 2
2 1 2 2
2 2 2 1
1 1
1 2
2 1 2 2

Sample Output

Yes
No
Yes


        
  
题意:给出棋盘和车的位置,车可以攻击所在的行列,问能否攻击指定矩阵的所有位置。

题解 :前缀和。前缀算法能够从一个给定数据空间中找出其前缀特征,即前缀集合。前缀集合具有确定性,能够匹配该前缀集合的数据一定属于该数据空间,否则将一定不属于该数据空间。

#include<cstdio>
#include<cstring>
using namespace std;

int ma[100100];
int mark[100100];
int main(){
	int t,n,m,k,q,i,j;
	int x,y,a,b,c,d;
	scanf ("%d",&t);
	while (t--){
		scanf ("%d %d %d %d",&n,&m,&k,&q);
		memset (mark,0,sizeof(mark));
		memset (ma,0,sizeof(ma));
		while (k--){
		scanf ("%d %d",&x,&y);
		mark[x]=1;//标记行
		ma[y]=1;//标记列	
		}
		for (i=1;i<=n;i++)
		mark[i]+=mark[i-1];
		for (j=1;j<=m;j++)
		ma[j]+=ma[j-1];
		while (q--){
			scanf ("%d %d %d %d",&a,&b,&c,&d);
			if (c-a+1==(mark[c]-mark[a-1])||(d-b+1)==(ma[d]-ma[b-1]))
			printf ("Yes\n");
			else
			printf ("No\n");
		}
		
	}
	return 0;
} 


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值