Sicily 1404. Hie with the Pie

1404. Hie with the Pie

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 <= n <= 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers th th 1 to n). The j value on the i line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8

// Problem#: 1404
// Submission#: 3245700
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include <algorithm>
#include <iostream>
#include <string>
#include <stdio.h>
#include <queue>
#include <string.h>
#include <vector>
#include <iomanip>
#include <map>
#include <stack>
#include <functional>
#include <list>
#include <cmath>
#include <set>
using namespace std;

const int MAX_N = 15;
const int MAX_STATUS = 1050;
const int INF = 99999999;

int N;
int G[MAX_N][MAX_N];
int dp[MAX_STATUS][MAX_N];

inline bool visitJ(int i, int j) {
    while (j--) i /= 2;
    return i % 2;
}

int main() {

    std::ios::sync_with_stdio(false);

    while (1) {
        cin >> N;
        if (N == 0) break;
        for (int i = 0; i <= N; i++) {
            for (int j = 0; j <= N; j++) {
                cin >> G[i][j];
            }
        }
        for (int k = 0; k <= N; k++) {
            for (int i = 0; i <= N; i++) {
                for (int j = 0; j <= N; j++) {
                    if (k != i && i != j && j != k && G[i][k] + G[k][j] < G[i][j]) G[i][j] = G[i][k] + G[k][j];
                }
            }
        }
        int max_status = pow(2, N);
        for (int i = 0; i < max_status; i++) {
            for (int j = 0; j <= N; j++) {
                dp[i][j] = 0;
            }
        }
        for (int i = 0; i < max_status; i++) {
            for (int j = 1; j <= N; j++) {
                if (visitJ(i, j - 1)) {
                    if (i == pow(2, j - 1)) {
                        dp[i][j] = G[0][j];
                    } else {
                        int lastI = i - pow(2, j - 1);
                        //cout << i << " " << j << " " << lastI << endl;
                        dp[i][j] = INF;
                        for (int k = 1; k <= N; k++) {
                            if (k != j && visitJ(i, k - 1) && dp[i][j] > dp[lastI][k] + G[k][j]) dp[i][j] = dp[lastI][k] + G[k][j];
                        }
                    }
                }
            }
        }
        int ans = dp[max_status - 1][1] + G[1][0];
        for (int i = 2; i <= N; i++) {
            if (dp[max_status - 1][i] + G[i][0] < ans) ans = dp[max_status - 1][i] + G[i][0];
        }
        cout << ans << endl;
    }

    //getchar();
    //getchar();
    
    return 0;
}                                 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值