九度OJ-1445:How Many Tables

  用并查集求连通分量数。与上题完全一样,不赘述。

题目描述:

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

输入:

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

输出:

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

样例输入:
2
5 3
1 2
2 3
4 5

5 1
2 5
样例输出:
2
4
#include <iostream> 
#define MAXSIZE 1000
using namespace std;
struct UFS{//UnionFindSet ´Ó0¿ªÊ¼ 
	int elem[MAXSIZE];
	int size;
	void initiate(int size){
		this->size=size;
		for (int i=0;i<size;i++)
			elem[i]=-1;
	}
	int findRoot(int x){//reduce deep 
		if (elem[x]==-1) 
			return x;
		else 
			return elem[x]=findRoot(elem[x]);
	}
	void unionSet(int x,int y){
		int xroot=findRoot(x),yroot=findRoot(y);
		if (xroot!=yroot)//if x and y are from different set 
			elem[xroot]=yroot; //merge xset into yset 
	}
};

int main(){
	int t,n,m;
	int a,b;
	int count;
	UFS ufs;
	cin>>t;
	for (int time=0;time<t;time++){
		cin>>n>>m;
		//initiate
		ufs.initiate(n);
		count=0;
		//input&&union
		for (int i=0;i<m;i++){
			cin>>a>>b;
			a-=1;b-=1;
			ufs.unionSet(a,b);
		}
		//count
		for (int i=0;i<ufs.size;i++){
			if (ufs.elem[i]==-1)
				count++;
		} 
		cout<<count<<endl;
	}

	return true;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值