九度OJ-1144:Freckles

  依然是最小生成树问题,使用并查集+kruskal实现。不赘述。

题目描述:

    In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad's back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley's engagement falls through. 
    Consider Dick's back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle. 

输入:

    The first line contains 0 < n <= 100, the number of freckles on Dick's back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.

输出:

    Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.

样例输入:
3
1.0 1.0
2.0 2.0
2.0 4.0
样例输出:
3.41
来源:
2009年北京大学计算机研究生机试真题
答疑:
解题遇到问题?分享解题心得?讨论本题请访问: http://t.jobdu.com/thread-7867-1-1.html
#include <iostream>
#include <vector>
#include <algorithm>
#include <cmath>
#include <iomanip>
#define MAXSIZE 100 
using namespace std;
struct Edge{
    int start,end;
    double weight;
    Edge(){
    }
    Edge(int start,int end,double weight){
        this->start=start;
        this->end=end;
        this->weight=weight;
    }
}; 
bool cmp(Edge a,Edge b){
    return a.weight<b.weight;
}
struct Vex{
    int root;
    double x,y;
    Vex(double x,double y){
        this->x=x;
        this->y=y;
        this->root=-1;
    }
};
struct Set{ //UnionFindSet ´Ó0¿ªÊ¼ 
    int setSize;
    vector<Edge> edge;
    vector<Vex> vex;
    int initSet(int setSize){
        this->setSize=setSize;
        edge.clear();
        vex.clear();
    }
    int findRoot(int x){
        if (vex[x].root==-1)
            return x;
        else
            return vex[x].root=findRoot(vex[x].root);
    }
    int unionSet(int x,int y){
        int xroot=findRoot(x);
        int yroot=findRoot(y);
        if(xroot!=yroot){//if x&y are not in the same set ÄÇô˵Ã÷ÆäÖÐÒ»¸ö»¹Êdzõ̬£¬Ò»´Î¶¼Ã»Óв¢¹ý
            vex[xroot].root=yroot; //merge xset into yset 
            return yroot;
        } 
        return -1;
    }
};
int main(){
    int n;
    double x,y,weight,totalWeight;
    Set set;
    while (cin>>n){
        //initiate
        set.initSet(n);
        totalWeight=0;
        //input
        for (int i=0;i<n;i++){
            cin>>x>>y;
            set.vex.push_back(Vex(x,y));
            for (int j=0;j<i;j++){
                set.edge.push_back(Edge(i,j,sqrt(pow(x-set.vex[j].x,2)+pow(y-set.vex[j].y,2))));
            }
        }
        //sort
        sort(&set.edge[0],&set.edge[0]+set.edge.size(),cmp);
        //kruskal
        for (int i=0;i<set.edge.size();i++){
            if (set.unionSet(set.edge[i].start,set.edge[i].end)!=-1){
                totalWeight+=set.edge[i].weight;
            }
        }
        //output
        cout<<setiosflags(ios::fixed)<<setprecision(2)<<totalWeight<<endl;
    }
    return true;
}
 
/**************************************************************
    Problem: 1144
    User: bit3125
    Language: C++
    Result: Accepted
    Time:10 ms
    Memory:1668 kb
****************************************************************/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值