九度OJ-1002:Grading

debug记录:

else{
	grade=(g3+(dif1<dif2?g1:g2))*1.0/2;
}
出了问题。刚开始的时候里头三目运算符没包着括号。以后记得写三目运算符要加括号,或者在写比较长的逻辑运算符的时候也要加上括号。

题目描述:

    Grading hundreds of thousands of Graduate Entrance Exams is a hard work. It is even harder to design a process to make the results as fair as possible. One way is to assign each exam problem to 3 independent experts. If they do not agree to each other, a judge is invited to make the final decision. Now you are asked to write a program to help this process.
    For each problem, there is a full-mark P and a tolerance T(<P) given. The grading rules are:
    • A problem will first be assigned to 2 experts, to obtain G1 and G2. If the difference is within the tolerance, that is, if |G1 - G2| ≤ T, this problem's grade will be the average of G1 and G2.
    • If the difference exceeds T, the 3rd expert will give G3.
    • If G3 is within the tolerance with either G1 or G2, but NOT both, then this problem's grade will be the average of G3 and the closest grade.
    • If G3 is within the tolerance with both G1 and G2, then this problem's grade will be the maximum of the three grades.
    • If G3 is within the tolerance with neither G1 nor G2, a judge will give the final grade GJ.

输入:

    Each input file may contain more than one test case.
    Each case occupies a line containing six positive integers: P, T, G1, G2, G3, and GJ, as described in the problem. It is guaranteed that all the grades are valid, that is, in the interval [0, P].

输出:

    For each test case you should output the final grade of the problem in a line. The answer must be accurate to 1 decimal place.

样例输入:
20 2 15 13 10 18
样例输出:
14.0
来源:
2011年浙江大学计算机及软件工程研究生机试真题
答疑:
解题遇到问题?分享解题心得?讨论本题请访问: http://t.jobdu.com/thread-7726-1-1.html
#include <cstdio>
using namespace std;
int abs(int x){
	return x>0?x:-x;
}
int main(){
	int p,t,g1,g2,g3,gj;
	double grade;
	int dif1,dif2;
	while (scanf("%d%d%d%d%d%d",&p,&t,&g1,&g2,&g3,&gj)!=EOF){
		if (abs(g1-g2)<=t){
			grade=(g1+g2)*1.0/2;
		}
		else {
			dif1=abs(g1-g3);
			dif2=abs(g2-g3);
			if (dif1<=t&&dif2<=t){
				int temp=g1>g2?g1:g2;
				grade=temp>g3?temp:g3;
			}
			else if (dif1>t&&dif2>t){
				grade=gj;
			}
			else{
				grade=(g3+(dif1<dif2?g1:g2))*1.0/2;
			}
		}
		//output
		printf("%.1lf\n",grade);
	}
	return true;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值