POJ2305 Basic remains

Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 4713
Accepted: 1997

Description

Given a base b and two non-negative base b integers p and m, compute p mod m and print the result as a base b integer. p mod m is defined as the smallest non-negative integer k such that p = a*m + k for some integer a.

Input

Input consists of a number of cases. Each case is represented by a line containing three unsigned integers. The first, b, is a decimal number between 2 and 10. The second, p, contains up to 1000 digits between 0 and b-1. The third, m, contains up to 9 digits between 0 and b-1. The last case is followed by a line containing 0.

Output

For each test case, print a line giving p mod m as a base-b integer.

Sample Input

2 1100 101
10 123456789123456789123456789 1000
0

Sample Output

10
789

Source



代码:
#include <iostream>
#include <cstdio>
#include <stdlib.h>
#include <string.h>
using namespace std;
void print(int r,int b)
{
if(r>0)
{
print(r/b,b);
printf("%d",r%b);
}
}
int main()
{
char p[1001],M[10];
int b,r;
int i,m;
for(;scanf("%d%s%s",&b,p,M);)
{
if(b==0)
break;
m=strtol(M,0,b);
r=0;
for(i=0;i<strlen(p);++i)
{
r=r*b+p[i]%48;
r%=m;
}
print(r,b);
puts(r?"":"0");
}


return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

杨鑫newlfe

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值