POJ 2828 Buy Tickets (线段树,单点更新)

http://poj.org/problem?id=2828

Buy Tickets
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 12307 Accepted: 6080

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Valiin the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

Source



题意

告诉你每个人进队时插在第几个人后面,问最终的队列结果。

分析:

最后一个进队的位置才能即刻确定下来,我们要从后往前操作。比如这个人插在当前第x个人的后面,那就意味着他前面要留出x个空位(反向操作,前面的人还没进队)。我们用线段树维护当前队列区间内剩余的空位,单点更新。


#include<cstdio>
#include<iostream>
#include<cstdlib>
#include<algorithm>
#include<ctime>
#include<cctype>
#include<cmath>
#include<string>
#include<cstring>
#include<stack>
#include<queue>
#include<list>
#include<vector>
#include<map>
#include<set>
#define sqr(x) ((x)*(x))
#define LL long long
#define itn int
#define INF 0x3f3f3f3f
#define PI 3.1415926535897932384626
#define eps 1e-10
#define maxm
#define maxn 200007

using namespace std;

itn pos[maxn],val[maxn];
int ans[maxn];
int rest[maxn<<2];

void build(int k,int l,int r)
{
    rest[k]=r-l;
    if (r-l==1) return ;
    build(k*2+1,l,l+r>>1);
    build(k*2+2,l+r>>1,r);
}

int query(int _rest,int k,int l,int r)
{
    rest[k]--;
    if (r-l==1) return l;
    if (_rest<rest[k*2+1])//左儿子区间内可放
    {
        return query(_rest,k*2+1,l,l+r>>1);
    }
    else//左儿子放不下,放在右儿子里
    {
        return query(_rest-rest[k*2+1],k*2+2,l+r>>1,r);
    }
}

int main()
{
    #ifndef ONLINE_JUDGE
        freopen("/home/fcbruce/文档/code/t","r",stdin);
    #endif // ONLINE_JUDGE

    int n;
    while (~scanf("%d",&n))
    {
        for (itn i=0;i<n;i++)
        {
            scanf("%d %d",pos+i,val+i);
        }

        build(0,0,n);

        for (int i=n-1;i>=0;i--)
        {
            ans[query(pos[i],0,0,n)]=val[i];
        }

        for (int i=0;i<n;i++)
            printf(i?" %d":"%d",ans[i]);
        puts("");
    }

    return 0;
}


  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值