最长回文

 

hdu:http://acm.hdu.edu.cn/showproblem.php?pid=3068

最长回文

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K(Java/Others)

Total Submission(s): 6495    Accepted Submission(s): 2240

 

 

Problem Description

给出一个只由小写英文字符a,b,c...y,z组成的字符串S,S中最长回文串的长度.

回文就是正反读都是一样的字符串,aba,abba

 

Input

输入有多组case,不超过120,每组输入为一行小写英文字符a,b,c...y,z组成的字符串S

两组case之间由空行隔开(该空行不用处理)

字符串长度len <= 110000

 

Output

每一行一个整数x,对应一组case,表示该组case的字符串中所包含的最长回文长度.

 

Sample Input

 

aaaa

abab

 

Sample Output

 

4
3


#include <iostream>
#include <string>
using namespace std;
char smytemp[230000] ;
int p[230000];

class Solution {
public:
    int longestPalindrome(string s) {
        
        int i=0;
        int maxlen =0;
        int mx = 0;
        int id = 0;
        //构造新串,格式为"#.#.#....#.#"

        memset(p,0,sizeof(p));
        memset(smytemp,0,sizeof(smytemp));
        int len = s.length();
        if (len == 0){
            return 0;
        }
        for ( i=0; i<len; ++i){
            smytemp[2*i]='#';
            smytemp[2*i+1]=s[i];
        }
        smytemp[2*i]='#';
        //cout<<2*i<<endl;
        len = 2*i+1;
        for ( i=1; i<len; ++i ){
            p[i] = mx>i ? min(p[2*id-i],mx-i):0;

            while ( i-p[i]-1>=0 && i+p[i]+1<len &&  smytemp[i+p[i]+1]==smytemp[i-p[i]-1] ){
                p[i]++;
            }
            if (i+p[i]>mx) {
                mx = i+p[i];
                id = i;
            }
        }
        for ( i=0 ;i<=mx; ++i){
            if ( maxlen < p[i] ){
                id = i;
                maxlen = p[i];
            }
        }
        return p[id];    
    }
};

int main()
{

    Solution s;
    string temp;
    while ( cin>>temp ){
        cout<<s.longestPalindrome(temp)<<endl;
    }
    return 0;

}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值