HDOJ 1241 Oil Deposits——邻接矩阵BFS和DFS


The Mine
  

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.

A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

 

Input 

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise $1 \le m \le 100$ and $1 \le n \le 100$. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either ` *', representing the absence of oil, or ` @', representing an oil pocket.

 

Output 

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

 

Sample Input 

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

 

Sample Output 

0
1
2
2

 BFS:


#include <stdio.h>
#include <stdlib.h>
#include <string.h>

char map[110][110];//图的存储
int vis[110][110];//标记是否被访问过
int num,n,m;

struct linshi
{
    int x;
    int y;
} ls[604];//用来存储找的符合题意的点的坐标

int bhx[]= {-1,-1,0,1,1,1,0,-1};//八个方向x的变化
int bhy[]= {0,1,1,1,0,-1,-1,-1};//八个方向y的变化

void bfs(int i,int j)
{
    struct linshi t,f;
    int a=0,b=0,k=0;
    t.x=i;
    t.y=j;
    ls[b++]=t;
    vis[t.x][t.y]=1;
    while(a<b)
    {
        t=ls[a++];//每次都访问一个符合题意的点
        for(k=0; k<8; k++)//寻找这个店的八个方向是否符合题意
        {
            f.x=t.x+bhx[k];
            f.y=t.y+bhy[k];
            if(f.x>=0&&f.x<n&&f.y>=0&&f.y<m&&(!vis[f.x][f.y])&&map[f.x][f.y]=='@')//判断
            {
                ls[b++]=f;//符合题意的被存进结构体里
                vis[f.x][f.y]=1;//标记这个点已经被访问过了
            }
        }
    }
    num++;
}

int main()
{
    int i,j;
    while(scanf("%d%d",&n,&m),n&&m)
    {
            memset(map,'\0',sizeof(map));
            memset(vis,0,sizeof(vis));
            memset(ls,0,sizeof(ls));
            num=0;
            for(i=0; i<n; i++)
            {
                scanf("%*c%s",map[i]);
            }
            for(i=0; i<n; i++)
            {
                for(j=0; j<m; j++)
                {
                    if(map[i][j]=='@'&&(!vis[i][j]))
                    {
                        bfs(i,j);
                    }
                }
            }
            printf("%d\n",num);
        }
    return 0;
}


DFS:

这个和上边差不多

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

char map[110][110];
int vis[100][110];
int num,n,m;

int bhx[]= {-1,-1,0,1,1,1,0,-1};
int bhy[]= {0,1,1,1,0,-1,-1,-1};

void dfs(int i,int j)
{
    int k,a,b;
    vis[i][j]=1;
    for(k=0;k<8;k++)
    {
        a=i+bhx[k];
        b=j+bhy[k];
        if(a>=0&&a<n&&b>=0&&b<m&&(!vis[a][b])&&map[a][b]=='@')
        {
            dfs(a,b);//每次发现合格的点,就以这个点为起点继续访问
        }
    }
}

int main()
{
    int i,j;
    while(scanf("%d%d",&n,&m),n&&m)
    {
        memset(map,'\0',sizeof(map));
        memset(vis,0,sizeof(vis));
        num=0;
        for(i=0;i<n;i++)
        {
            scanf("%*c%s",map[i]);
        }
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                if(map[i][j]=='@'&&(!vis[i][j]))
                {
                    dfs(i,j);
                    num++;
                }
            }
        }
        printf("%d\n",num);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值