UVAOJ 10878 ——Decode the tape 模拟

15 篇文章 0 订阅

Decode the tape
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %ll

Description

 

"Machines take me by surprise with great frequency."

Alan Turing

Your boss has just unearthed a roll of old computer tapes. The tapes have holes in them and might contain some sort of useful information. It falls to you to figure out what is written on them.

Input

The input will contain one tape.

Output

Output the message that is written on the tape.

Sample Input

___________
| o   .  o|
|  o  .   |
| ooo .  o|
| ooo .o o|
| oo o.  o|
| oo  . oo|
| oo o. oo|
|  o  .   |
| oo  . o |
| ooo . o |
| oo o.ooo|
| ooo .ooo|
| oo o.oo |
|  o  .   |
| oo  .oo |
| oo o.ooo|
| oooo.   |
|  o  .   |
| oo o. o |
| ooo .o o|
| oo o.o o|
| ooo .   |
| ooo . oo|
|  o  .   |
| oo o.ooo|
| ooo .oo |
| oo  .o o|
| ooo . o |
|  o  .   |
| ooo .o  |
| oo o.   |
| oo  .o o|
|  o  .   |
| oo o.o  |
| oo  .  o|
| oooo. o |
| oooo.  o|
|  o  .   |
| oo  .o  |
| oo o.ooo|
| oo  .ooo|
|  o o.oo |
|    o. o |
___________

Sample Output

A quick brown fox jumps over the lazy dog.


坑题,本题后台不知有多少数据,反正二维数组我没能开出那么大的内存来直接装下它,只能每次输入一行,然后转换成字符再输出,即使是这样,一维数组开到10000都没对,只好开到100000,才AC。。。。。


#include <stdio.h>
#include <string.h>

char mp[1000010];
int s[1000010];

int zh(int x)
{
    int sum = 0,y = 0;
    for(int i = x - 1;i >= 0;i--)
    {
        sum += (s[i] * (1 << y));
        y++;
    }
    return sum;
}

int main()
{
    int x;
    while(gets(mp))
    {
        int m = strlen(mp);
        x = 0;
        for(int i = 0;i < m;i++)
        {
            if(mp[i] == ' ')
                s[x++] = 0;
            else if(mp[i] == 'o')
                s[x++] = 1;
        }
        if(x != 0)
        printf("%c",zh(x));
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值