UVAOJ 10420 List of Conquests ——字典树(哈希用法),map

10 篇文章 0 订阅
9 篇文章 0 订阅

List of Conquests
Input: standard input
Output: standard output
Time Limit: 2 seconds

In Act I, Leporello is telling Donna Elvira about his master's long list of conquests:

``This is the list of the beauties my master has loved, a list I've made out myself: take a look, read it with me. In Italy six hundred and forty, in Germany two hundred and thirty-one, a hundred in France, ninety-one in Turkey; but in Spain already a thousand and three! Among them are country girls, waiting-maids, city beauties; there are countesses, baronesses, marchionesses, princesses: women of every rank, of every size, of every age.'' (Madamina, il catalogo è questo)

As Leporello records all the ``beauties'' Don Giovanni ``loved'' in chronological order, it is very troublesome for him to present his master's conquest to others because he needs to count the number of ``beauties'' by their nationality each time. You are to help Leporello to count.

Input

The input consists of at most 2000 lines, but the first. The first line contains a number n, indicating that there will be n more lines. Each following line, with at most 75 characters, contains a country (the first word) and the name of a woman (the rest of the words in the line) Giovanni loved. You may assume that the name of all countries consist of only one word.

Output

The output consists of lines in alphabetical order. Each line starts with the name of a country, followed by the total number of women Giovanni loved in that country, separated by a space.

Sample Input

3 
Spain Donna Elvira 
England Jane Doe 
Spain Donna Anna 

Sample Output

England 1 

Spain 2


Problem-setter: Thomas Tang, Queens University, Canada

 

 

“Failure to produce a reasonably good and error free problem set illustrates two things a) Lack of creativity b) Lack of commitment”



果断字典树:


#include <stdio.h>
#include <string.h>
#include <ctype.h>
#include <algorithm>

using namespace std;

const char *p = " ";

struct node
{
    char s[110];
    int no;
} zfc[2010];

struct Zds
{
    int flag;
    int next[52];
} ls[150010];

int num;
int top;

bool cmp(node a,node b)
{
    return strcmp(a.s,b.s) < 0;
}

void creat(char *fg,int xb,int len)
{
    int zh;
    for(char *q = fg; *q != '\0'; q++)
    {
        if(isupper(*q))
            zh = *q - 'A' + 26;
        else if(islower(*q))
            zh = *q - 'a';
        if(ls[xb].next[zh] == 0)
        {
            ls[top].flag = 0;
            memset(ls[top].next,0,sizeof(ls[top].next));
            ls[xb].next[zh] = top;
            xb = top++;
        }
        else
        {
            xb = ls[xb].next[zh];
        }
    }
    if(ls[xb].flag == 0)
    {
        ls[xb].flag = num;
        strcpy(zfc[num].s,fg);
        zfc[num].no = 1;
        num++;
    }
    else
    {
        int a = ls[xb].flag;
        zfc[a].no++;
    }
}

int main()
{
    int n;
    char sr[80];
    char zhh[80];
    num = 1;
    top = 1;
    memset(ls[0].next,0,sizeof(ls[0].next));
    scanf("%d",&n);
    getchar();
    while(n--)
    {

        int k = 0;
        gets(sr);
        for(int i = 0; sr[i] != ' ' && sr[i] != '\0'; i++)
        {
            zhh[k++] = sr[i];
        }
        zhh[k] = '\0';
        creat(zhh,0,k);
    }
    sort(zfc + 1,zfc + num,cmp);
    for(int i = 1; i < num; i++)
    {
        printf("%s %d\n",zfc[i].s,zfc[i].no);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值