UVA 591 ---Box of Bricks 模拟枚举

15 篇文章 0 订阅

Box of Bricks
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Download as PDF


  Box of Bricks 

Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. ``Look, I've built a wall!'', he tells his older sister Alice. ``Nah, you should make all stacks the same height. Then you would have a real wall.'', she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?

Input 

The input consists of several data sets. Each set begins with a line containing the number  n of stacks Bob has built. The next line contains n numbers, the heights  h i of the  n stacks. You may assume  $1 Ÿ\le n \leŸ 50$ and  $1 \leŸ h_i Ÿ\le 100$.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.

Output 

For each set, first print the number of the set, as shown in the sample output. Then print the line ``  The minimum number of moves is k.'', where  k is the minimum number of bricks that have to be moved in order to make all the stacks the same height.

Output a blank line after each set.

Sample Input 

6
5 2 4 1 7 5
0

Sample Output 

Set #1
The minimum number of moves is 5.



Miguel A. Revilla
1998-03-10


#include <stdio.h>
#include <string.h>
#include <math.h>

int main()
{
    int s[55],sum,n,c = 0;
    while(scanf("%d",&n),n)
    {
        sum = 0;
        for(int i = 0;i < n;i++)
        {
            scanf("%d",&s[i]);
            sum += s[i];
        }
        int ave = sum / n;
        int cnt = 0;
        for(int i = 0;i < n;i++)
        {
            cnt += fabs(ave - s[i]);//找平均数和每摞砖的差距,求模然后相加,这便是移动的砖块数的两倍,那第一摞一个放到第二摞其实是算一个,我这里都加进去了
        }
        printf("Set #%d\n",++c);
        printf("The minimum number of moves is %d.\n",cnt / 2);//最后要除以2
        printf("\n");
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值