寒假训练--KMP--Power Strings

Power Strings

Time Limit: 1000MS Memory limit: 65536K

题目描述

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

输入

  Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

输出

  For each s you should print the largest n such that s = a^n for some string a.

示例输入

abcd
aaaa
ababab
.

示例输出

1
4
3

提示

  This problem has huge input, use scanf instead of cin to avoid time limit exceed.
在字符串中找到循环串,并计算循环串的次数,主要找到循环串的字符个数,计算next之后得到的next[strlen(str)] 的值为整个字符串的最长前缀和后缀的长度,则刚好空出一个循环节的长度 , ll = l - next[strlen(str)] ;

来源

 

示例程序
#include <stdio.h>
#include <stdlib.h>
char str[1000002];
int next[1000002] ;
void getnext()
{
    int j = 0 , k = -1 , l = strlen(str) ;
    next[0] = -1 ;
    while(j < l)
    {
        if(k==-1 || str[j]==str[k])
        {
            j++; k++;
            next[j] = k ;
        }
        else
            k = next[k] ;
    }
}
int main()
{
    int i , j , li , lj ;
    while(scanf("%s", str)!=EOF)
    {
        if(strcmp(str,".")==0) break;
        li = strlen(str);
        getnext();
        lj = li - next[li]  ;
        if(li%lj==0)
            printf("%d\n", li/lj);
        else
            printf("1\n");
        memset(str,0,sizeof(str));
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值