Girls and Boys
Time Limit: 5000MS | Memory Limit: 10000K | |
Total Submissions: 10242 | Accepted: 4540 |
Description
In the second year of the university somebody started a study on the romantic relations between the students. The relation "romantically involved" is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been "romantically involved". The result of the program is the number of students in such a set.
Input
The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:
the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)
The student_identifier is an integer number between 0 and n-1 (n <=500 ), for n subjects.
the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)
The student_identifier is an integer number between 0 and n-1 (n <=500 ), for n subjects.
Output
For each given data set, the program should write to standard output a line containing the result.
Sample Input
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
Sample Output
5 2
Source
Southeastern Europe 2000
第一次做二分匹配的题目,建图和判断是不是二分匹配最重要了
题目大意,找最大独立集,最大独立集 = 总点数 - 最大匹配数 ; 或者 最大独立集 = 匹配数 / 2 + 未匹配点
找到建图的方法,在通过增广路来找到最大匹配数
建图: 以给出的n个点,使左右均为n个点,然后进行匹配,最后会得到2倍的正常的最大匹配数
#include <stdio.h>
#include <string.h>
bool p[510][510] ;
int n1 , n2 , m , n , ans ;
int link[510] , temp[510] ;
int f(int x)
{
int i , j ;
for(i = 0 ; i < n ; i++)
{
if( p[x][i] && p[i][x] && !temp[i] )
{
temp[i] = true ;
if( link[i] == -1 || f(link[i]) )
{
link[i] = x ;
return true ;
}
}
}
return false ;
}
int main()
{
int i , j , t ;
while(scanf("%d", &n)!=EOF)
{
memset(p,0,sizeof(p));
memset(link,-1,sizeof(link));
ans = 0 ;
for(t = 0 ; t < n ; t++)
{
scanf("%d: (%d)", &i, &m);
while(m--)
{
scanf("%d", &j);
p[i][j] = true ;
}
}
for(i = 0 ; i < n ; i++)
{
memset(temp,0,sizeof(temp));
if( f(i) )
{
ans++ ;
}
}
printf("%d\n", n-ans/2 );
}
return 0;
}