hdu1796--How many integers can you find(容斥原理)

How many integers can you find
Time Limit:5000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
 

Input

  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
 

Output

  For each case, output the number.
 

Sample Input

     
     
12 2 2 3
 

Sample Output

     
     
7


题目大意:给出一个n和一个集合,m个数,问在1到n内 能被m中的数正除的有多少?

可以理解为在1到n内,是m中的数的倍数的数有多少?  

在容斥原理中,用二进制数表示第i个数取没取,如果取了奇数个数,加上。 取了偶数个数,减去

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;
#define LL long long
LL a[12] ;
LL n , m , k , i , j , cnt , num , ans ;
LL gcd(LL x,LL y)
{
    return x == 0 ? y : gcd(y%x,x) ;
}
int main()
{
    while(scanf("%lld %lld", &n, &m) != EOF)
    {
        ans = 0 ;
        for(i = 0 ; i < m ; i++)
        {
            scanf("%lld", &a[i]) ;
            if( a[i] == 0 )
            {
                i-- ;
                m-- ;
            }
        }
        cnt = 1 << m ;
        for(i = 1 ; i < cnt ; i++)
        {
            k = 1 ;
            num = 0 ;
            for(j = 0 ; j < m ; j++)
            {
                if( 1<<j & i )
                {
                    k = a[j] * k / ( gcd(k,a[j]) ) ;
                    num++ ;
                }
            }
            if( num % 2 )
            {
                ans += n/k ;
                if( n % k == 0 )
                    ans-- ;
            }
            else
            {
                ans -= n/k ;
                if(n%k == 0)
                    ans++ ;
            }
        }
        printf("%lld\n", ans) ;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值