Appoint description:
Description
Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
Input
There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
Output
For each case, output the number.
Sample Input
12 2 2 3
Sample Output
7
题目大意:给出一个n和一个集合,m个数,问在1到n内 能被m中的数正除的有多少?
可以理解为在1到n内,是m中的数的倍数的数有多少?
在容斥原理中,用二进制数表示第i个数取没取,如果取了奇数个数,加上。 取了偶数个数,减去
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;
#define LL long long
LL a[12] ;
LL n , m , k , i , j , cnt , num , ans ;
LL gcd(LL x,LL y)
{
return x == 0 ? y : gcd(y%x,x) ;
}
int main()
{
while(scanf("%lld %lld", &n, &m) != EOF)
{
ans = 0 ;
for(i = 0 ; i < m ; i++)
{
scanf("%lld", &a[i]) ;
if( a[i] == 0 )
{
i-- ;
m-- ;
}
}
cnt = 1 << m ;
for(i = 1 ; i < cnt ; i++)
{
k = 1 ;
num = 0 ;
for(j = 0 ; j < m ; j++)
{
if( 1<<j & i )
{
k = a[j] * k / ( gcd(k,a[j]) ) ;
num++ ;
}
}
if( num % 2 )
{
ans += n/k ;
if( n % k == 0 )
ans-- ;
}
else
{
ans -= n/k ;
if(n%k == 0)
ans++ ;
}
}
printf("%lld\n", ans) ;
}
return 0;
}