HDU - 1796 How many integers can you find 容斥原理

Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.

Input

  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.

Output

  For each case, output the number.

Sample Input

12 2
2 3

Sample Output

7

题解:发现数据并不大最多10个,状压一下,容斥即可

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
#define lowbit(x) (x&(-x))
#define INF 0x3f3f3f3f
const int N=12;
typedef long long ll;
ll n,m,a[N];
int main()
{

    while(scanf("%lld%lld",&n,&m)!=EOF)
    {
        int len=0;
        for(ll i=1;i<=m;i++)
        {
            ll x;
            scanf("%lld",&x);
            if(x) a[++len]=x;
        }
        m=len;
        ll mm=(1<<m)-1;
        ll ans=0;
        n--;
        for(ll i=1;i<=mm;i++)
        {
            ll tmp=i;
            ll cnt=0;
            ll res=1;
            while(tmp)
            {
                if(tmp&1) cnt++;
                tmp/=2;
            }
            for(int j=1;j<=m;j++)
            {
                if(i&(1<<(j-1)))
                {
                    res=res*a[j]/__gcd(res,a[j]);
                }
            }
            if(cnt&1) ans+=n/res;
            else ans-=n/res;
        }
        printf("%lld\n",ans);
    }
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值