HDU-1796-How many integers can you find【dfs+容斥原理】

How many integers can you find
Problem Description
Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
Input
There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0< N<2^31,0< M<=10, and the M integer are non-negative and won’t exceed 20.
Output
For each case, output the number.
Sample Input
12 2
2 3
Sample Output
7

题意:
求小于n的能够被集合中任意数字整除的数的个数
代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;

#define ll long long
int a[110];
int ans,num,n,m,d;
ll gcd(ll a,ll b)
{
    if(b==0) return a;
    return gcd(b,a%b);
}

void dfs(int x,ll y,int z)
{
    y=a[x]/gcd(a[x],y)*y;
    if(z&1)
        ans+=(m-1)/y;
    else
        ans-=(m-1)/y;
    for(int i=x+1; i<num; i++)
        dfs(i,y,z+1);
}

int main()
{
    while(~scanf("%d%d",&m,&n))
    {
        ans=0;
        num=0;
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&d);
            if(d)
                a[num++]=d;
        }
        for(int i=0; i<num; i++)
            dfs(i,a[i],1);
        printf("%d\n",ans);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值