poj1463--hdu1054--Strategic Game(树形DP练习4)

Strategic Game
Time Limit:10000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him? 

Your program should find the minimum number of soldiers that Bob has to put for a given tree. 

The input file contains several data sets in text format. Each data set represents a tree with the following description: 

the number of nodes 
the description of each node in the following format 
node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifier 
or 
node_identifier:(0) 

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data. 

For example for the tree: 



the solution is one soldier ( at the node 1). 

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table: 
 

Sample Input

     
     
4 0:(1) 1 1:(2) 2 3 2:(0) 3:(0) 5 3:(3) 1 4 2 1:(1) 0 2:(0) 0:(0) 4:(0)
 

Sample Output

     
     
1 2
 

给出有向图,要求找出用最少的人数可以看守所有的边。

dp[i][0] 以i为根的子树,i上不放人时,需要的最少人数。

dp[i][1] 以i为根的子树,i上放人时,需要的最少人数。

状态转移方程:j为i的子节点

dp[i][0] += dp[j][1] ;

dp[i][1] += max( dp[j][0],dp[j][1] ) ;

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;
struct node{
    int u , v ;
    int next ;
}edge[2000];
int head[2000] , cnt ;
int dp[2000][2] ;
void add(int u,int v)
{
    edge[cnt].u = u ; edge[cnt].v = v;
    edge[cnt].next = head[u] ;
    head[u] = cnt++ ;
    return ;
}
void dfs(int u)
{
    int i , v ;
    dp[u][0] = 0 ;
    dp[u][1] = 1 ;
    for(i = head[u] ; i != -1 ; i = edge[i].next)
    {
        v = edge[i].v ;
        dfs(v) ;
        dp[u][0] += dp[v][1] ;
        dp[u][1] += min(dp[v][0],dp[v][1]) ;
    }
    return ;
}
int main()
{
    int n , m , i , j , u , v , rt ;
    while( scanf("%d", &n) != EOF )
    {
        cnt = 0 ;
        rt = (n-1)*(n)/2 ;
        memset(head,-1,sizeof(head)) ;
        memset(dp,0,sizeof(dp)) ;
        for(i = 0 ; i < n ; i++)
        {
            scanf("%d:(%d)", &u, &m) ;
            while( m-- )
            {
                scanf("%d", &v) ;
                add(u,v) ;
                rt -= v ;
            }
        }
        dfs(rt) ;
        printf("%d\n", min(dp[rt][0],dp[rt][1])) ;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值